Serialized Form
-
Package org.springframework.security.web.webauthn.api
-
Class org.springframework.security.web.webauthn.api.AuthenticatorAssertionResponse
class AuthenticatorAssertionResponse extends AuthenticatorResponse implements Serializable- serialVersionUID:
- 324976481675434298L
-
Class org.springframework.security.web.webauthn.api.AuthenticatorAttachment
class AuthenticatorAttachment extends Object implements Serializable- serialVersionUID:
- 8446133215195918090L
-
Serialization Methods
-
readResolve
- Throws:
ObjectStreamException
-
-
Serialized Fields
-
value
String value
-
-
Class org.springframework.security.web.webauthn.api.AuthenticatorAttestationResponse
class AuthenticatorAttestationResponse extends AuthenticatorResponse implements Serializable- serialVersionUID:
- -1628559840895428945L
-
Serialized Fields
-
attestationObject
Bytes attestationObject
-
transports
@Nullable List<AuthenticatorTransport> transports
-
-
Class org.springframework.security.web.webauthn.api.AuthenticatorResponse
class AuthenticatorResponse extends Object implements Serializable-
Serialized Fields
-
clientDataJSON
Bytes clientDataJSON
-
-
-
Class org.springframework.security.web.webauthn.api.AuthenticatorTransport
class AuthenticatorTransport extends Object implements Serializable- serialVersionUID:
- -5617945441117386982L
-
Serialization Methods
-
readResolve
- Throws:
ObjectStreamException
-
-
Serialized Fields
-
value
String value
-
-
Class org.springframework.security.web.webauthn.api.Bytes
class Bytes extends Object implements Serializable- serialVersionUID:
- -3278138671365709777L
-
Serialized Fields
-
bytes
byte[] bytes
-
-
Class org.springframework.security.web.webauthn.api.CredentialPropertiesOutput
class CredentialPropertiesOutput extends Object implements Serializable- serialVersionUID:
- -3201699313968303331L
-
Serialized Fields
-
output
CredentialPropertiesOutput.ExtensionOutput output
-
-
Class org.springframework.security.web.webauthn.api.CredentialPropertiesOutput.ExtensionOutput
class ExtensionOutput extends Object implements Serializable- serialVersionUID:
- 4557406414847424019L
-
Serialized Fields
-
rk
boolean rk
-
-
Class org.springframework.security.web.webauthn.api.CredProtectAuthenticationExtensionsClientInput
class CredProtectAuthenticationExtensionsClientInput extends Object implements Serializable- serialVersionUID:
- -6418175591005843455L
-
Serialized Fields
-
Class org.springframework.security.web.webauthn.api.CredProtectAuthenticationExtensionsClientInput.CredProtect
class CredProtect extends Object implements Serializable- serialVersionUID:
- 109597301115842688L
-
Serialized Fields
-
credProtectionPolicy
CredProtectAuthenticationExtensionsClientInput.CredProtect.ProtectionPolicy credProtectionPolicy
-
enforceCredentialProtectionPolicy
boolean enforceCredentialProtectionPolicy
-
-
Class org.springframework.security.web.webauthn.api.ImmutableAuthenticationExtensionsClientInput
class ImmutableAuthenticationExtensionsClientInput extends Object implements Serializable- serialVersionUID:
- -1738152485672656808L
-
Class org.springframework.security.web.webauthn.api.ImmutableAuthenticationExtensionsClientInputs
class ImmutableAuthenticationExtensionsClientInputs extends Object implements Serializable- serialVersionUID:
- 4277817521578485720L
-
Serialized Fields
-
inputs
List<AuthenticationExtensionsClientInput> inputs
-
-
Class org.springframework.security.web.webauthn.api.ImmutableAuthenticationExtensionsClientOutputs
class ImmutableAuthenticationExtensionsClientOutputs extends Object implements Serializable- serialVersionUID:
- -4656390173585180393L
-
Serialized Fields
-
outputs
List<AuthenticationExtensionsClientOutput<?>> outputs
-
-
Class org.springframework.security.web.webauthn.api.ImmutablePublicKeyCredentialUserEntity
class ImmutablePublicKeyCredentialUserEntity extends Object implements Serializable- serialVersionUID:
- -3438693960347279759L
-
Serialized Fields
-
displayName
@Nullable String displayName
A human-palatable name for the user account, intended only for display. The Relying Party SHOULD let the user choose this, and SHOULD NOT restrict the choice more than necessary. Relying Parties SHOULD perform enforcement, as prescribed in Section 2.3 of [RFC8266] for the Nickname Profile of the PRECIS FreeformClass [RFC8264], when setting displayName's value, or displaying the value to the user. This string MAY contain language and direction metadata. Relying Parties SHOULD consider providing this information. See 6.4.2 Language and Direction Encoding about how this metadata is encoded. Clients SHOULD perform enforcement, as prescribed in Section 2.3 of [RFC8266] for the Nickname Profile of the PRECIS FreeformClass [RFC8264], on displayName's value prior to displaying the value to the user or including the value as a parameter of the authenticatorMakeCredential operation. When clients, client platforms, or authenticators display a displayName's value, they should always use UI elements to provide a clear boundary around the displayed value, and not allow overflow into other elements [css-overflow-3]. Authenticators MUST accept and store a 64-byte minimum length for a displayName member's value. Authenticators MAY truncate a displayName member's value so that it fits within 64 bytes. See 6.4.1 String Truncation about truncation and other considerations. -
id
Bytes id
The user handle of the user account entity. A user handle is an opaque byte sequence with a maximum size of 64 bytes, and is not meant to be displayed to the user. To ensure secure operation, authentication and authorization decisions MUST be made on the basis of this id member, not the displayName nor name members. See Section 6.1 of [RFC8266]. The user handle MUST NOT contain personally identifying information about the user, such as a username or e-mail address; see 14.6.1 User Handle Contents for details. The user handle MUST NOT be empty, though it MAY be null. Note: the user handle ought not be a constant value across different accounts, even for non-discoverable credentials, because some authenticators always create discoverable credentials. Thus a constant user handle would prevent a user from using such an authenticator with more than one account at the Relying Party. -
name
String name
When inherited by PublicKeyCredentialUserEntity, it is a human-palatable identifier for a user account. It is intended only for display, i.e., aiding the user in determining the difference between user accounts with similar displayNames. For example, "alexm", "alex.mueller@example.com" or "+14255551234". The Relying Party MAY let the user choose this value. The Relying Party SHOULD perform enforcement, as prescribed in Section 3.4.3 of [RFC8265] for the UsernameCasePreserved Profile of the PRECIS IdentifierClass [RFC8264], when setting name's value, or displaying the value to the user. This string MAY contain language and direction metadata. Relying Parties SHOULD consider providing this information. See 6.4.2 Language and Direction Encoding about how this metadata is encoded. Clients SHOULD perform enforcement, as prescribed in Section 3.4.3 of [RFC8265] for the UsernameCasePreserved Profile of the PRECIS IdentifierClass [RFC8264], on name's value prior to displaying the value to the user or including the value as a parameter of the authenticatorMakeCredential operation.
-
-
Class org.springframework.security.web.webauthn.api.PublicKeyCredential
class PublicKeyCredential extends Object implements Serializable- serialVersionUID:
- -1864035469276082606L
-
Serialized Fields
-
authenticatorAttachment
@Nullable AuthenticatorAttachment authenticatorAttachment
-
clientExtensionResults
@Nullable AuthenticationExtensionsClientOutputs clientExtensionResults
-
id
String id
-
rawId
Bytes rawId
-
response
R extends AuthenticatorResponse response
-
type
@Nullable PublicKeyCredentialType type
-
-
Class org.springframework.security.web.webauthn.api.PublicKeyCredentialDescriptor
class PublicKeyCredentialDescriptor extends Object implements Serializable- serialVersionUID:
- 8793385059692676240L
-
Serialized Fields
-
id
@Nullable Bytes id
-
transports
@Nullable Set<AuthenticatorTransport> transports
-
type
PublicKeyCredentialType type
-
-
Class org.springframework.security.web.webauthn.api.PublicKeyCredentialRequestOptions
class PublicKeyCredentialRequestOptions extends Object implements Serializable- serialVersionUID:
- -2970057592835694354L
-
Serialized Fields
-
allowCredentials
List<PublicKeyCredentialDescriptor> allowCredentials
-
challenge
Bytes challenge
-
extensions
AuthenticationExtensionsClientInputs extensions
-
rpId
@Nullable String rpId
-
timeout
Duration timeout
-
userVerification
@Nullable UserVerificationRequirement userVerification
-
-
Class org.springframework.security.web.webauthn.api.PublicKeyCredentialType
class PublicKeyCredentialType extends Object implements Serializable- serialVersionUID:
- 7025333122210061679L
-
Serialization Methods
-
readResolve
- Throws:
ObjectStreamException
-
-
Serialized Fields
-
value
String value
-
-
Class org.springframework.security.web.webauthn.api.UserVerificationRequirement
class UserVerificationRequirement extends Object implements Serializable- serialVersionUID:
- -2801001231345540040L
-
Serialization Methods
-
readResolve
- Throws:
ObjectStreamException
-
-
Serialized Fields
-
value
String value
-
-
-
Package org.springframework.security.web.webauthn.authentication
-
Class org.springframework.security.web.webauthn.authentication.WebAuthnAuthentication
class WebAuthnAuthentication extends org.springframework.security.authentication.AbstractAuthenticationToken implements Serializable- serialVersionUID:
- -4879907158750659197L
-
Serialized Fields
-
principal
PublicKeyCredentialUserEntity principal
-
-
Class org.springframework.security.web.webauthn.authentication.WebAuthnAuthenticationRequestToken
class WebAuthnAuthenticationRequestToken extends org.springframework.security.authentication.AbstractAuthenticationToken implements Serializable- serialVersionUID:
- -1682693433877522403L
-
Serialized Fields
-
webAuthnRequest
RelyingPartyAuthenticationRequest webAuthnRequest
-
-
-
Package org.springframework.security.web.webauthn.jackson
-
Class org.springframework.security.web.webauthn.jackson.WebauthnJackson2Module
class WebauthnJackson2Module extends com.fasterxml.jackson.databind.module.SimpleModule implements Serializable -
Class org.springframework.security.web.webauthn.jackson.WebauthnJacksonModule
class WebauthnJacksonModule extends org.springframework.security.jackson.SecurityJacksonModule implements Serializable
-
-
Package org.springframework.security.web.webauthn.management
-
Class org.springframework.security.web.webauthn.management.RelyingPartyAuthenticationRequest
class RelyingPartyAuthenticationRequest extends Object implements Serializable- serialVersionUID:
- -928083091875202086L
-
Serialized Fields
-
publicKey
PublicKeyCredential<AuthenticatorAssertionResponse> publicKey
-
requestOptions
PublicKeyCredentialRequestOptions requestOptions
-
-