All Classes and Interfaces

Class
Description
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Camellia - based on RFC 3713, about half the size of CamelliaEngine.
 
 
 
 
Camellia - based on RFC 3713, about half the size of CamelliaEngine.
 
 
Checksum handler as the highest level API for checksum stuffs defined in Kerberos RFC3961.
 
Based on MIT krb5 cmac.c
 
 
 
 
 
Reference: http://introcs.cs.princeton.edu/java/51data/CRC32.java
 
 
 
Ref.
 
 
 
 
 
 
 
 
 
"When using the Diffie-Hellman key agreement method, implementations MUST support Oakley 1024-bit Modular Exponential (MODP) well-known group 2 [RFC2412] and Oakley 2048-bit MODP well-known group 14 [RFC3526] and SHOULD support Oakley 4096-bit MODP well-known group 16 [RFC3526]."
The client-side of Diffie-Hellman key agreement for Kerberos PKINIT.
The server-side of Diffie-Hellman key agreement for Kerberos PKINIT.
 
Encryption handler as the highest level API for encryption stuffs defined in Kerberos RFC3961.
Encryption provider that provides encryption/decryption functions for implementing an encryption type defined by Kerberos RFC3961.
 
Implementing FAST (RFC6113) armor key related algorithms.
Hash provider that provides hash function for implementing a checksum type defined by Kerberos RFC3961.
Ref.
 
 
 
 
 
Use jdk SecureRandom to implement RandomProvider, so it can be used on windows and linux.
 
 
 
 
 
Copied from Mina project and modified a bit
 
 
 
 
use "/dev/urandom", which is on linux, to implement RandomProvider, so it should be used on linux.
Based on RFC3961, with ref.
 
From RFC 4556: Define the function octetstring2key() as follows: octetstring2key(x) == random-to-key(K-truncate( SHA1(0x00 | x) | SHA1(0x01 | x) | SHA1(0x02 | x) | ... )) where x is an octet string; | is the concatenation operator; 0x00, 0x01, 0x02, etc. are each represented as a single octet; random- to-key() is an operation that generates a protocol key from a bitstring of length K; and K-truncate truncates its input to the first K bits.
 
 
A provider to generate random and secure bytes provided with seeds, as Java SecureRandom does.
Ref.