Package io.gravitee.gateway.api.http
Interface HttpHeaderNames
-
public interface HttpHeaderNames- Author:
- David BRASSELY (david.brassely at graviteesource.com), GraviteeSource Team
-
-
Field Summary
-
-
-
Field Detail
-
ACCEPT
static final CharSequence ACCEPT
See {@link HTTP/1.1 documentation}.
-
ACCEPT_CHARSET
static final String ACCEPT_CHARSET
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
ACCEPT_ENCODING
static final String ACCEPT_ENCODING
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
ACCEPT_LANGUAGE
static final String ACCEPT_LANGUAGE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
ACCEPT_RANGES
static final String ACCEPT_RANGES
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_ALLOW_CREDENTIALS
static final String ACCESS_CONTROL_ALLOW_CREDENTIALS
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_ALLOW_HEADERS
static final String ACCESS_CONTROL_ALLOW_HEADERS
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_ALLOW_METHODS
static final String ACCESS_CONTROL_ALLOW_METHODS
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_ALLOW_ORIGIN
static final String ACCESS_CONTROL_ALLOW_ORIGIN
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_EXPOSE_HEADERS
static final String ACCESS_CONTROL_EXPOSE_HEADERS
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_MAX_AGE
static final String ACCESS_CONTROL_MAX_AGE
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_REQUEST_HEADERS
static final String ACCESS_CONTROL_REQUEST_HEADERS
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
ACCESS_CONTROL_REQUEST_METHOD
static final String ACCESS_CONTROL_REQUEST_METHOD
See {@link CORS documentation}.- See Also:
- Constant Field Values
-
AGE
static final String AGE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
ALLOW
static final String ALLOW
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
AUTHORIZATION
static final String AUTHORIZATION
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CACHE_CONTROL
static final String CACHE_CONTROL
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONNECTION
static final String CONNECTION
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONTENT_DISPOSITION
static final String CONTENT_DISPOSITION
See {@link IETF RFC-2183}.- See Also:
- Constant Field Values
-
CONTENT_ENCODING
static final String CONTENT_ENCODING
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONTENT_ID
static final String CONTENT_ID
See {@link IETF RFC-2392}.- See Also:
- Constant Field Values
-
CONTENT_LANGUAGE
static final String CONTENT_LANGUAGE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONTENT_LENGTH
static final String CONTENT_LENGTH
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONTENT_LOCATION
static final String CONTENT_LOCATION
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONTENT_MD5
static final String CONTENT_MD5
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONTENT_RANGE
static final String CONTENT_RANGE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
CONTENT_TYPE
static final String CONTENT_TYPE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
COOKIE
static final String COOKIE
See {@link IETF RFC 2109}.- See Also:
- Constant Field Values
-
DATE
static final String DATE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
ETAG
static final String ETAG
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
EXPIRES
static final String EXPIRES
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
EXPECT
static final String EXPECT
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
FORWARDED
static final String FORWARDED
See {@link IETF RFC 7239}.- See Also:
- Constant Field Values
-
FROM
static final String FROM
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
HOST
static final String HOST
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
IF_MATCH
static final String IF_MATCH
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
IF_MODIFIED_SINCE
static final String IF_MODIFIED_SINCE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
IF_NONE_MATCH
static final String IF_NONE_MATCH
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
IF_UNMODIFIED_SINCE
static final String IF_UNMODIFIED_SINCE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
KEEP_ALIVE
static final String KEEP_ALIVE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
LAST_MODIFIED
static final String LAST_MODIFIED
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
LOCATION
static final String LOCATION
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
LINK
static final String LINK
See {@link Web Linking (IETF RFC-5988) documentation}.- See Also:
- Constant Field Values
-
MAX_FORWARDS
static final String MAX_FORWARDS
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
MIME_VERSION
static final String MIME_VERSION
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
ORIGIN
static final String ORIGIN
https://tools.ietf.org/id/draft-abarth-origin-03.html#rfc.section.2- See Also:
- Constant Field Values
-
PRAGMA
static final String PRAGMA
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
PROXY_AUTHENTICATE
static final String PROXY_AUTHENTICATE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
PROXY_AUTHORIZATION
static final String PROXY_AUTHORIZATION
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
PROXY_CONNECTION
static final String PROXY_CONNECTION
- See Also:
- Constant Field Values
-
RANGE
static final String RANGE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
REFERER
static final String REFERER
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
RETRY_AFTER
static final String RETRY_AFTER
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
SERVER
static final String SERVER
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
SET_COOKIE
static final String SET_COOKIE
See {@link IETF RFC 2109}.- See Also:
- Constant Field Values
-
SET_COOKIE2
static final String SET_COOKIE2
See {@link IETF RFC 2965}.- See Also:
- Constant Field Values
-
TE
static final String TE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
TRAILER
static final String TRAILER
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
TRANSFER_ENCODING
static final String TRANSFER_ENCODING
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
UPGRADE
static final String UPGRADE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
USER_AGENT
static final String USER_AGENT
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
VARY
static final String VARY
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
VIA
static final String VIA
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
WARNING
static final String WARNING
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
WWW_AUTHENTICATE
static final String WWW_AUTHENTICATE
See {@link HTTP/1.1 documentation}.- See Also:
- Constant Field Values
-
X_FORWARDED_FOR
static final String X_FORWARDED_FOR
- See Also:
- Constant Field Values
-
X_FORWARDED_PROTO
static final String X_FORWARDED_PROTO
- See Also:
- Constant Field Values
-
X_FORWARDED_SERVER
static final String X_FORWARDED_SERVER
- See Also:
- Constant Field Values
-
X_FORWARDED_HOST
static final String X_FORWARDED_HOST
- See Also:
- Constant Field Values
-
X_FORWARDED_PORT
static final String X_FORWARDED_PORT
- See Also:
- Constant Field Values
-
X_FORWARDED_PREFIX
static final String X_FORWARDED_PREFIX
- See Also:
- Constant Field Values
-
-