public static class EmbeddedLinkSubEntity.Builder extends java.lang.Object implements Builder<EmbeddedLinkSubEntity>
EmbeddedLinkSubEntity.Builder.| Constructor and Description |
|---|
Builder()
Constructs an instance of
EmbeddedLinkSubEntity.Builder. |
| Modifier and Type | Method and Description |
|---|---|
EmbeddedLinkSubEntity |
build()
Constructs an instance of
EmbeddedLinkSubEntity with the
current state of the builder. |
void |
clear()
Clears the state of the builder.
|
EmbeddedLinkSubEntity.Builder |
href(java.net.URI href)
Adds the href to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
klass(java.lang.String klass)
Adds the class provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
klasses(java.lang.String... klasses)
Adds the classes provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
rel(Relation rel)
Adds the relation provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
rel(java.lang.String rel)
Adds the relation provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
rel(java.net.URI rel)
Adds the relation provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
rels(Relation... rels)
Adds the relations provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
rels(java.lang.String... rels)
Adds the relations provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
rels(java.net.URI... rels)
Adds the relations provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
title(java.lang.String title)
Adds the title provided to the current state of the builder.
|
EmbeddedLinkSubEntity.Builder |
type(java.lang.String type)
Adds the type provided to the current state of the builder.
|
public Builder()
EmbeddedLinkSubEntity.Builder.public EmbeddedLinkSubEntity.Builder klass(java.lang.String klass)
klass - Describes the nature of an entity's content based on the current representation.
Possible values are implementation-dependent and should be documented.public EmbeddedLinkSubEntity.Builder klasses(java.lang.String... klasses)
klasses - Descriptions of the nature of an entity's content based on the current representation.
Possible values are implementation-dependent and should be documented.public EmbeddedLinkSubEntity.Builder title(java.lang.String title)
title - Descriptive text about the entity.public EmbeddedLinkSubEntity.Builder rel(java.lang.String rel) throws java.net.URISyntaxException
rel - The relationship of the sub-entity to its parent, per Web Linking (RFC5899).java.net.URISyntaxException - Thrown if the textual representation of the relation
is not a registered relation, and is not a valid URI. All extension relations must
be in the form of a URI.public EmbeddedLinkSubEntity.Builder rel(java.net.URI rel)
rel - The relationship of the sub-entity to its parent, per Web Linking (RFC5899).public EmbeddedLinkSubEntity.Builder rel(Relation rel)
rel - The relationship of the sub-entity to its parent, per Web Linking (RFC5899).public EmbeddedLinkSubEntity.Builder rels(java.lang.String... rels) throws java.net.URISyntaxException
rels - The relationships of the sub-entity to its parent, per Web Linking (RFC5899).java.net.URISyntaxException - Thrown if the textual representation of the relation
is not a registered relation, and is not a valid URI. All extension relations must
be in the form of a URI.public EmbeddedLinkSubEntity.Builder rels(java.net.URI... rels)
rels - The relationships of the sub-entity to its parent, per Web Linking (RFC5899).public EmbeddedLinkSubEntity.Builder rels(Relation... rels)
rels - The relationships of the sub-entity to its parent, per Web Linking (RFC5899).public EmbeddedLinkSubEntity.Builder type(java.lang.String type)
type - Defines media type of the linked resource, per Web Linking (RFC5988).
For the syntax, see RFC2045 (section 5.1), RFC4288 (section 4.2), RFC6838 (section 4.2).public EmbeddedLinkSubEntity.Builder href(java.net.URI href)
href - The URI of the linked sub-entity.public void clear()
clear in interface Builder<EmbeddedLinkSubEntity>public EmbeddedLinkSubEntity build()
EmbeddedLinkSubEntity with the
current state of the builder.build in interface Builder<EmbeddedLinkSubEntity>EmbeddedLinkSubEntity with the current state of the builder.Copyright © 2017. All Rights Reserved.