Uses of Class
com.google.cloud.security.privateca.v1.SubjectAltNames.Builder
-
Uses of SubjectAltNames.Builder in com.google.cloud.security.privateca.v1
Methods in com.google.cloud.security.privateca.v1 that return SubjectAltNames.BuilderModifier and TypeMethodDescriptionSubjectAltNames.Builder.addAllCustomSans(Iterable<? extends X509Extension> values) Contains additional subject alternative name values.SubjectAltNames.Builder.addAllDnsNames(Iterable<String> values) Contains only valid, fully-qualified host names.SubjectAltNames.Builder.addAllEmailAddresses(Iterable<String> values) Contains only valid RFC 2822 E-mail addresses.SubjectAltNames.Builder.addAllIpAddresses(Iterable<String> values) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.SubjectAltNames.Builder.addAllUris(Iterable<String> values) Contains only valid RFC 3986 URIs.SubjectAltNames.Builder.addCustomSans(int index, X509Extension value) Contains additional subject alternative name values.SubjectAltNames.Builder.addCustomSans(int index, X509Extension.Builder builderForValue) Contains additional subject alternative name values.SubjectAltNames.Builder.addCustomSans(X509Extension value) Contains additional subject alternative name values.SubjectAltNames.Builder.addCustomSans(X509Extension.Builder builderForValue) Contains additional subject alternative name values.SubjectAltNames.Builder.addDnsNames(String value) Contains only valid, fully-qualified host names.SubjectAltNames.Builder.addDnsNamesBytes(com.google.protobuf.ByteString value) Contains only valid, fully-qualified host names.SubjectAltNames.Builder.addEmailAddresses(String value) Contains only valid RFC 2822 E-mail addresses.SubjectAltNames.Builder.addEmailAddressesBytes(com.google.protobuf.ByteString value) Contains only valid RFC 2822 E-mail addresses.SubjectAltNames.Builder.addIpAddresses(String value) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.SubjectAltNames.Builder.addIpAddressesBytes(com.google.protobuf.ByteString value) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.Contains only valid RFC 3986 URIs.SubjectAltNames.Builder.addUrisBytes(com.google.protobuf.ByteString value) Contains only valid RFC 3986 URIs.SubjectAltNames.Builder.clear()SubjectAltNames.Builder.clearCustomSans()Contains additional subject alternative name values.SubjectAltNames.Builder.clearDnsNames()Contains only valid, fully-qualified host names.SubjectAltNames.Builder.clearEmailAddresses()Contains only valid RFC 2822 E-mail addresses.SubjectAltNames.Builder.clearIpAddresses()Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.SubjectAltNames.Builder.clearUris()Contains only valid RFC 3986 URIs.CertificateConfig.SubjectConfig.Builder.getSubjectAltNameBuilder()Optional.CertificateDescription.SubjectDescription.Builder.getSubjectAltNameBuilder()The subject alternative name fields.SubjectAltNames.Builder.mergeFrom(SubjectAltNames other) SubjectAltNames.Builder.mergeFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) SubjectAltNames.Builder.mergeFrom(com.google.protobuf.Message other) static SubjectAltNames.BuilderSubjectAltNames.newBuilder()static SubjectAltNames.BuilderSubjectAltNames.newBuilder(SubjectAltNames prototype) SubjectAltNames.newBuilderForType()protected SubjectAltNames.BuilderSubjectAltNames.newBuilderForType(com.google.protobuf.AbstractMessage.BuilderParent parent) SubjectAltNames.Builder.removeCustomSans(int index) Contains additional subject alternative name values.SubjectAltNames.Builder.setCustomSans(int index, X509Extension value) Contains additional subject alternative name values.SubjectAltNames.Builder.setCustomSans(int index, X509Extension.Builder builderForValue) Contains additional subject alternative name values.SubjectAltNames.Builder.setDnsNames(int index, String value) Contains only valid, fully-qualified host names.SubjectAltNames.Builder.setEmailAddresses(int index, String value) Contains only valid RFC 2822 E-mail addresses.SubjectAltNames.Builder.setIpAddresses(int index, String value) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.Contains only valid RFC 3986 URIs.SubjectAltNames.toBuilder()Methods in com.google.cloud.security.privateca.v1 with parameters of type SubjectAltNames.BuilderModifier and TypeMethodDescriptionCertificateConfig.SubjectConfig.Builder.setSubjectAltName(SubjectAltNames.Builder builderForValue) Optional.CertificateDescription.SubjectDescription.Builder.setSubjectAltName(SubjectAltNames.Builder builderForValue) The subject alternative name fields.