Interface SubjectAltNamesOrBuilder
- All Superinterfaces:
com.google.protobuf.MessageLiteOrBuilder,com.google.protobuf.MessageOrBuilder
- All Known Implementing Classes:
SubjectAltNames,SubjectAltNames.Builder
@Generated
public interface SubjectAltNamesOrBuilder
extends com.google.protobuf.MessageOrBuilder
-
Method Summary
Modifier and TypeMethodDescriptiongetCustomSans(int index) Contains additional subject alternative name values.intContains additional subject alternative name values.Contains additional subject alternative name values.getCustomSansOrBuilder(int index) Contains additional subject alternative name values.List<? extends X509ExtensionOrBuilder>Contains additional subject alternative name values.getDnsNames(int index) Contains only valid, fully-qualified host names.com.google.protobuf.ByteStringgetDnsNamesBytes(int index) Contains only valid, fully-qualified host names.intContains only valid, fully-qualified host names.Contains only valid, fully-qualified host names.getEmailAddresses(int index) Contains only valid RFC 2822 E-mail addresses.com.google.protobuf.ByteStringgetEmailAddressesBytes(int index) Contains only valid RFC 2822 E-mail addresses.intContains only valid RFC 2822 E-mail addresses.Contains only valid RFC 2822 E-mail addresses.getIpAddresses(int index) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.com.google.protobuf.ByteStringgetIpAddressesBytes(int index) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.intContains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.getUris(int index) Contains only valid RFC 3986 URIs.com.google.protobuf.ByteStringgetUrisBytes(int index) Contains only valid RFC 3986 URIs.intContains only valid RFC 3986 URIs.Contains only valid RFC 3986 URIs.Methods inherited from interface com.google.protobuf.MessageLiteOrBuilder
isInitializedMethods inherited from interface com.google.protobuf.MessageOrBuilder
findInitializationErrors, getAllFields, getDefaultInstanceForType, getDescriptorForType, getField, getInitializationErrorString, getOneofFieldDescriptor, getRepeatedField, getRepeatedFieldCount, getUnknownFields, hasField, hasOneof
-
Method Details
-
getDnsNamesList
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Returns:
- A list containing the dnsNames.
-
getDnsNamesCount
int getDnsNamesCount()Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Returns:
- The count of dnsNames.
-
getDnsNames
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Parameters:
index- The index of the element to return.- Returns:
- The dnsNames at the given index.
-
getDnsNamesBytes
com.google.protobuf.ByteString getDnsNamesBytes(int index) Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the dnsNames at the given index.
-
getUrisList
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Returns:
- A list containing the uris.
-
getUrisCount
int getUrisCount()Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Returns:
- The count of uris.
-
getUris
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Parameters:
index- The index of the element to return.- Returns:
- The uris at the given index.
-
getUrisBytes
com.google.protobuf.ByteString getUrisBytes(int index) Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the uris at the given index.
-
getEmailAddressesList
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Returns:
- A list containing the emailAddresses.
-
getEmailAddressesCount
int getEmailAddressesCount()Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Returns:
- The count of emailAddresses.
-
getEmailAddresses
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Parameters:
index- The index of the element to return.- Returns:
- The emailAddresses at the given index.
-
getEmailAddressesBytes
com.google.protobuf.ByteString getEmailAddressesBytes(int index) Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the emailAddresses at the given index.
-
getIpAddressesList
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Returns:
- A list containing the ipAddresses.
-
getIpAddressesCount
int getIpAddressesCount()Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Returns:
- The count of ipAddresses.
-
getIpAddresses
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Parameters:
index- The index of the element to return.- Returns:
- The ipAddresses at the given index.
-
getIpAddressesBytes
com.google.protobuf.ByteString getIpAddressesBytes(int index) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the ipAddresses at the given index.
-
getCustomSansList
List<X509Extension> getCustomSansList()Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
getCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
getCustomSansCount
int getCustomSansCount()Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
getCustomSansOrBuilderList
List<? extends X509ExtensionOrBuilder> getCustomSansOrBuilderList()Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
getCustomSansOrBuilder
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;
-