Class SubjectAltNames

java.lang.Object
com.google.protobuf.AbstractMessageLite
com.google.protobuf.AbstractMessage
com.google.protobuf.GeneratedMessage
com.google.cloud.security.privateca.v1.SubjectAltNames
All Implemented Interfaces:
SubjectAltNamesOrBuilder, com.google.protobuf.Message, com.google.protobuf.MessageLite, com.google.protobuf.MessageLiteOrBuilder, com.google.protobuf.MessageOrBuilder, Serializable

@Generated public final class SubjectAltNames extends com.google.protobuf.GeneratedMessage implements SubjectAltNamesOrBuilder
 [SubjectAltNames][google.cloud.security.privateca.v1.SubjectAltNames]
 corresponds to a more modern way of listing what the asserted identity is in
 a certificate (i.e., compared to the "common name" in the distinguished
 name).
 
Protobuf type google.cloud.security.privateca.v1.SubjectAltNames
See Also:
  • Nested Class Summary

    Nested Classes
    Modifier and Type
    Class
    Description
    static final class 
    [SubjectAltNames][google.cloud.security.privateca.v1.SubjectAltNames] corresponds to a more modern way of listing what the asserted identity is in a certificate (i.e., compared to the "common name" in the distinguished name).

    Nested classes/interfaces inherited from class com.google.protobuf.GeneratedMessage

    com.google.protobuf.GeneratedMessage.ExtendableBuilder<MessageT extends com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT>,BuilderT extends com.google.protobuf.GeneratedMessage.ExtendableBuilder<MessageT,BuilderT>>, com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT extends com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT>>, com.google.protobuf.GeneratedMessage.ExtendableMessageOrBuilder<MessageT extends com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT>>, com.google.protobuf.GeneratedMessage.FieldAccessorTable, com.google.protobuf.GeneratedMessage.GeneratedExtension<ContainingT extends com.google.protobuf.Message,T extends Object>, com.google.protobuf.GeneratedMessage.UnusedPrivateParameter

    Nested classes/interfaces inherited from class com.google.protobuf.AbstractMessage

    com.google.protobuf.AbstractMessage.BuilderParent

    Nested classes/interfaces inherited from class com.google.protobuf.AbstractMessageLite

    com.google.protobuf.AbstractMessageLite.InternalOneOfEnum
  • Field Summary

    Fields
    Modifier and Type
    Field
    Description
    static final int
     
    static final int
     
    static final int
     
    static final int
     
    static final int
     

    Fields inherited from class com.google.protobuf.GeneratedMessage

    alwaysUseFieldBuilders, loggedPre22TypeNames, unknownFields

    Fields inherited from class com.google.protobuf.AbstractMessage

    memoizedSize

    Fields inherited from class com.google.protobuf.AbstractMessageLite

    memoizedHashCode
  • Method Summary

    Modifier and Type
    Method
    Description
    boolean
     
    getCustomSans(int index)
    Contains additional subject alternative name values.
    int
    Contains additional subject alternative name values.
    Contains additional subject alternative name values.
    Contains additional subject alternative name values.
    Contains additional subject alternative name values.
     
     
    static final com.google.protobuf.Descriptors.Descriptor
     
    getDnsNames(int index)
    Contains only valid, fully-qualified host names.
    com.google.protobuf.ByteString
    getDnsNamesBytes(int index)
    Contains only valid, fully-qualified host names.
    int
    Contains only valid, fully-qualified host names.
    com.google.protobuf.ProtocolStringList
    Contains only valid, fully-qualified host names.
    getEmailAddresses(int index)
    Contains only valid RFC 2822 E-mail addresses.
    com.google.protobuf.ByteString
    Contains only valid RFC 2822 E-mail addresses.
    int
    Contains only valid RFC 2822 E-mail addresses.
    com.google.protobuf.ProtocolStringList
    Contains only valid RFC 2822 E-mail addresses.
    getIpAddresses(int index)
    Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
    com.google.protobuf.ByteString
    Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
    int
    Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
    com.google.protobuf.ProtocolStringList
    Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
    com.google.protobuf.Parser<SubjectAltNames>
     
    int
     
    getUris(int index)
    Contains only valid RFC 3986 URIs.
    com.google.protobuf.ByteString
    getUrisBytes(int index)
    Contains only valid RFC 3986 URIs.
    int
    Contains only valid RFC 3986 URIs.
    com.google.protobuf.ProtocolStringList
    Contains only valid RFC 3986 URIs.
    int
     
    protected com.google.protobuf.GeneratedMessage.FieldAccessorTable
     
    final boolean
     
     
     
     
    newBuilderForType(com.google.protobuf.AbstractMessage.BuilderParent parent)
     
     
    parseDelimitedFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry)
     
    parseFrom(byte[] data)
     
    parseFrom(byte[] data, com.google.protobuf.ExtensionRegistryLite extensionRegistry)
     
    parseFrom(com.google.protobuf.ByteString data)
     
    parseFrom(com.google.protobuf.ByteString data, com.google.protobuf.ExtensionRegistryLite extensionRegistry)
     
    parseFrom(com.google.protobuf.CodedInputStream input)
     
    parseFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry)
     
     
    parseFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry)
     
     
    parseFrom(ByteBuffer data, com.google.protobuf.ExtensionRegistryLite extensionRegistry)
     
    static com.google.protobuf.Parser<SubjectAltNames>
     
     
    void
    writeTo(com.google.protobuf.CodedOutputStream output)
     

    Methods inherited from class com.google.protobuf.GeneratedMessage

    canUseUnsafe, computeStringSize, computeStringSizeNoTag, emptyBooleanList, emptyDoubleList, emptyFloatList, emptyIntList, emptyList, emptyLongList, getAllFields, getDescriptorForType, getField, getOneofFieldDescriptor, getRepeatedField, getRepeatedFieldCount, getUnknownFields, hasField, hasOneof, internalGetMapField, internalGetMapFieldReflection, isStringEmpty, makeExtensionsImmutable, makeMutableCopy, makeMutableCopy, mergeFromAndMakeImmutableInternal, newFileScopedGeneratedExtension, newInstance, newMessageScopedGeneratedExtension, parseDelimitedWithIOException, parseDelimitedWithIOException, parseUnknownField, parseUnknownFieldProto3, parseWithIOException, parseWithIOException, parseWithIOException, parseWithIOException, serializeBooleanMapTo, serializeIntegerMapTo, serializeLongMapTo, serializeStringMapTo, writeReplace, writeString, writeStringNoTag

    Methods inherited from class com.google.protobuf.AbstractMessage

    findInitializationErrors, getInitializationErrorString, hashFields, toString

    Methods inherited from class com.google.protobuf.AbstractMessageLite

    addAll, checkByteStringIsUtf8, toByteArray, toByteString, writeDelimitedTo, writeTo

    Methods inherited from class java.lang.Object

    clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    Methods inherited from interface com.google.protobuf.MessageLite

    toByteArray, toByteString, writeDelimitedTo, writeTo

    Methods inherited from interface com.google.protobuf.MessageOrBuilder

    findInitializationErrors, getAllFields, getDescriptorForType, getField, getInitializationErrorString, getOneofFieldDescriptor, getRepeatedField, getRepeatedFieldCount, getUnknownFields, hasField, hasOneof
  • Field Details

    • DNS_NAMES_FIELD_NUMBER

      public static final int DNS_NAMES_FIELD_NUMBER
      See Also:
    • URIS_FIELD_NUMBER

      public static final int URIS_FIELD_NUMBER
      See Also:
    • EMAIL_ADDRESSES_FIELD_NUMBER

      public static final int EMAIL_ADDRESSES_FIELD_NUMBER
      See Also:
    • IP_ADDRESSES_FIELD_NUMBER

      public static final int IP_ADDRESSES_FIELD_NUMBER
      See Also:
    • CUSTOM_SANS_FIELD_NUMBER

      public static final int CUSTOM_SANS_FIELD_NUMBER
      See Also:
  • Method Details

    • getDescriptor

      public static final com.google.protobuf.Descriptors.Descriptor getDescriptor()
    • internalGetFieldAccessorTable

      protected com.google.protobuf.GeneratedMessage.FieldAccessorTable internalGetFieldAccessorTable()
      Specified by:
      internalGetFieldAccessorTable in class com.google.protobuf.GeneratedMessage
    • getDnsNamesList

      public com.google.protobuf.ProtocolStringList getDnsNamesList()
       Contains only valid, fully-qualified host names.
       
      repeated string dns_names = 1;
      Specified by:
      getDnsNamesList in interface SubjectAltNamesOrBuilder
      Returns:
      A list containing the dnsNames.
    • getDnsNamesCount

      public int getDnsNamesCount()
       Contains only valid, fully-qualified host names.
       
      repeated string dns_names = 1;
      Specified by:
      getDnsNamesCount in interface SubjectAltNamesOrBuilder
      Returns:
      The count of dnsNames.
    • getDnsNames

      public String getDnsNames(int index)
       Contains only valid, fully-qualified host names.
       
      repeated string dns_names = 1;
      Specified by:
      getDnsNames in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the element to return.
      Returns:
      The dnsNames at the given index.
    • getDnsNamesBytes

      public com.google.protobuf.ByteString getDnsNamesBytes(int index)
       Contains only valid, fully-qualified host names.
       
      repeated string dns_names = 1;
      Specified by:
      getDnsNamesBytes in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the value to return.
      Returns:
      The bytes of the dnsNames at the given index.
    • getUrisList

      public com.google.protobuf.ProtocolStringList getUrisList()
       Contains only valid RFC 3986 URIs.
       
      repeated string uris = 2;
      Specified by:
      getUrisList in interface SubjectAltNamesOrBuilder
      Returns:
      A list containing the uris.
    • getUrisCount

      public int getUrisCount()
       Contains only valid RFC 3986 URIs.
       
      repeated string uris = 2;
      Specified by:
      getUrisCount in interface SubjectAltNamesOrBuilder
      Returns:
      The count of uris.
    • getUris

      public String getUris(int index)
       Contains only valid RFC 3986 URIs.
       
      repeated string uris = 2;
      Specified by:
      getUris in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the element to return.
      Returns:
      The uris at the given index.
    • getUrisBytes

      public com.google.protobuf.ByteString getUrisBytes(int index)
       Contains only valid RFC 3986 URIs.
       
      repeated string uris = 2;
      Specified by:
      getUrisBytes in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the value to return.
      Returns:
      The bytes of the uris at the given index.
    • getEmailAddressesList

      public com.google.protobuf.ProtocolStringList getEmailAddressesList()
       Contains only valid RFC 2822 E-mail addresses.
       
      repeated string email_addresses = 3;
      Specified by:
      getEmailAddressesList in interface SubjectAltNamesOrBuilder
      Returns:
      A list containing the emailAddresses.
    • getEmailAddressesCount

      public int getEmailAddressesCount()
       Contains only valid RFC 2822 E-mail addresses.
       
      repeated string email_addresses = 3;
      Specified by:
      getEmailAddressesCount in interface SubjectAltNamesOrBuilder
      Returns:
      The count of emailAddresses.
    • getEmailAddresses

      public String getEmailAddresses(int index)
       Contains only valid RFC 2822 E-mail addresses.
       
      repeated string email_addresses = 3;
      Specified by:
      getEmailAddresses in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the element to return.
      Returns:
      The emailAddresses at the given index.
    • getEmailAddressesBytes

      public com.google.protobuf.ByteString getEmailAddressesBytes(int index)
       Contains only valid RFC 2822 E-mail addresses.
       
      repeated string email_addresses = 3;
      Specified by:
      getEmailAddressesBytes in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the value to return.
      Returns:
      The bytes of the emailAddresses at the given index.
    • getIpAddressesList

      public com.google.protobuf.ProtocolStringList getIpAddressesList()
       Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
       
      repeated string ip_addresses = 4;
      Specified by:
      getIpAddressesList in interface SubjectAltNamesOrBuilder
      Returns:
      A list containing the ipAddresses.
    • getIpAddressesCount

      public int getIpAddressesCount()
       Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
       
      repeated string ip_addresses = 4;
      Specified by:
      getIpAddressesCount in interface SubjectAltNamesOrBuilder
      Returns:
      The count of ipAddresses.
    • getIpAddresses

      public String getIpAddresses(int index)
       Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
       
      repeated string ip_addresses = 4;
      Specified by:
      getIpAddresses in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the element to return.
      Returns:
      The ipAddresses at the given index.
    • getIpAddressesBytes

      public com.google.protobuf.ByteString getIpAddressesBytes(int index)
       Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
       
      repeated string ip_addresses = 4;
      Specified by:
      getIpAddressesBytes in interface SubjectAltNamesOrBuilder
      Parameters:
      index - The index of the value to return.
      Returns:
      The bytes of the ipAddresses at the given index.
    • getCustomSansList

      public List<X509Extension> getCustomSansList()
       Contains additional subject alternative name values.
       For each custom_san, the `value` field must contain an ASN.1 encoded
       UTF8String.
       
      repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;
      Specified by:
      getCustomSansList in interface SubjectAltNamesOrBuilder
    • getCustomSansOrBuilderList

      public List<? extends X509ExtensionOrBuilder> getCustomSansOrBuilderList()
       Contains additional subject alternative name values.
       For each custom_san, the `value` field must contain an ASN.1 encoded
       UTF8String.
       
      repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;
      Specified by:
      getCustomSansOrBuilderList in interface SubjectAltNamesOrBuilder
    • getCustomSansCount

      public int getCustomSansCount()
       Contains additional subject alternative name values.
       For each custom_san, the `value` field must contain an ASN.1 encoded
       UTF8String.
       
      repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;
      Specified by:
      getCustomSansCount in interface SubjectAltNamesOrBuilder
    • getCustomSans

      public X509Extension getCustomSans(int index)
       Contains additional subject alternative name values.
       For each custom_san, the `value` field must contain an ASN.1 encoded
       UTF8String.
       
      repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;
      Specified by:
      getCustomSans in interface SubjectAltNamesOrBuilder
    • getCustomSansOrBuilder

      public X509ExtensionOrBuilder getCustomSansOrBuilder(int index)
       Contains additional subject alternative name values.
       For each custom_san, the `value` field must contain an ASN.1 encoded
       UTF8String.
       
      repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;
      Specified by:
      getCustomSansOrBuilder in interface SubjectAltNamesOrBuilder
    • isInitialized

      public final boolean isInitialized()
      Specified by:
      isInitialized in interface com.google.protobuf.MessageLiteOrBuilder
      Overrides:
      isInitialized in class com.google.protobuf.GeneratedMessage
    • writeTo

      public void writeTo(com.google.protobuf.CodedOutputStream output) throws IOException
      Specified by:
      writeTo in interface com.google.protobuf.MessageLite
      Overrides:
      writeTo in class com.google.protobuf.GeneratedMessage
      Throws:
      IOException
    • getSerializedSize

      public int getSerializedSize()
      Specified by:
      getSerializedSize in interface com.google.protobuf.MessageLite
      Overrides:
      getSerializedSize in class com.google.protobuf.GeneratedMessage
    • equals

      public boolean equals(Object obj)
      Specified by:
      equals in interface com.google.protobuf.Message
      Overrides:
      equals in class com.google.protobuf.AbstractMessage
    • hashCode

      public int hashCode()
      Specified by:
      hashCode in interface com.google.protobuf.Message
      Overrides:
      hashCode in class com.google.protobuf.AbstractMessage
    • parseFrom

      public static SubjectAltNames parseFrom(ByteBuffer data) throws com.google.protobuf.InvalidProtocolBufferException
      Throws:
      com.google.protobuf.InvalidProtocolBufferException
    • parseFrom

      public static SubjectAltNames parseFrom(ByteBuffer data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws com.google.protobuf.InvalidProtocolBufferException
      Throws:
      com.google.protobuf.InvalidProtocolBufferException
    • parseFrom

      public static SubjectAltNames parseFrom(com.google.protobuf.ByteString data) throws com.google.protobuf.InvalidProtocolBufferException
      Throws:
      com.google.protobuf.InvalidProtocolBufferException
    • parseFrom

      public static SubjectAltNames parseFrom(com.google.protobuf.ByteString data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws com.google.protobuf.InvalidProtocolBufferException
      Throws:
      com.google.protobuf.InvalidProtocolBufferException
    • parseFrom

      public static SubjectAltNames parseFrom(byte[] data) throws com.google.protobuf.InvalidProtocolBufferException
      Throws:
      com.google.protobuf.InvalidProtocolBufferException
    • parseFrom

      public static SubjectAltNames parseFrom(byte[] data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws com.google.protobuf.InvalidProtocolBufferException
      Throws:
      com.google.protobuf.InvalidProtocolBufferException
    • parseFrom

      public static SubjectAltNames parseFrom(InputStream input) throws IOException
      Throws:
      IOException
    • parseFrom

      public static SubjectAltNames parseFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException
      Throws:
      IOException
    • parseDelimitedFrom

      public static SubjectAltNames parseDelimitedFrom(InputStream input) throws IOException
      Throws:
      IOException
    • parseDelimitedFrom

      public static SubjectAltNames parseDelimitedFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException
      Throws:
      IOException
    • parseFrom

      public static SubjectAltNames parseFrom(com.google.protobuf.CodedInputStream input) throws IOException
      Throws:
      IOException
    • parseFrom

      public static SubjectAltNames parseFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException
      Throws:
      IOException
    • newBuilderForType

      public SubjectAltNames.Builder newBuilderForType()
      Specified by:
      newBuilderForType in interface com.google.protobuf.Message
      Specified by:
      newBuilderForType in interface com.google.protobuf.MessageLite
    • newBuilder

      public static SubjectAltNames.Builder newBuilder()
    • newBuilder

      public static SubjectAltNames.Builder newBuilder(SubjectAltNames prototype)
    • toBuilder

      public SubjectAltNames.Builder toBuilder()
      Specified by:
      toBuilder in interface com.google.protobuf.Message
      Specified by:
      toBuilder in interface com.google.protobuf.MessageLite
    • newBuilderForType

      protected SubjectAltNames.Builder newBuilderForType(com.google.protobuf.AbstractMessage.BuilderParent parent)
      Overrides:
      newBuilderForType in class com.google.protobuf.AbstractMessage
    • getDefaultInstance

      public static SubjectAltNames getDefaultInstance()
    • parser

      public static com.google.protobuf.Parser<SubjectAltNames> parser()
    • getParserForType

      public com.google.protobuf.Parser<SubjectAltNames> getParserForType()
      Specified by:
      getParserForType in interface com.google.protobuf.Message
      Specified by:
      getParserForType in interface com.google.protobuf.MessageLite
      Overrides:
      getParserForType in class com.google.protobuf.GeneratedMessage
    • getDefaultInstanceForType

      public SubjectAltNames getDefaultInstanceForType()
      Specified by:
      getDefaultInstanceForType in interface com.google.protobuf.MessageLiteOrBuilder
      Specified by:
      getDefaultInstanceForType in interface com.google.protobuf.MessageOrBuilder