Class SubjectAltNames.Builder
java.lang.Object
com.google.protobuf.AbstractMessageLite.Builder
com.google.protobuf.AbstractMessage.Builder<BuilderT>
com.google.protobuf.GeneratedMessage.Builder<SubjectAltNames.Builder>
com.google.cloud.security.privateca.v1.SubjectAltNames.Builder
- All Implemented Interfaces:
SubjectAltNamesOrBuilder,com.google.protobuf.Message.Builder,com.google.protobuf.MessageLite.Builder,com.google.protobuf.MessageLiteOrBuilder,com.google.protobuf.MessageOrBuilder,Cloneable
- Enclosing class:
- SubjectAltNames
public static final class SubjectAltNames.Builder
extends com.google.protobuf.GeneratedMessage.Builder<SubjectAltNames.Builder>
implements SubjectAltNamesOrBuilder
[SubjectAltNames][google.cloud.security.privateca.v1.SubjectAltNames] corresponds to a more modern way of listing what the asserted identity is in a certificate (i.e., compared to the "common name" in the distinguished name).Protobuf type
google.cloud.security.privateca.v1.SubjectAltNames-
Method Summary
Modifier and TypeMethodDescriptionaddAllCustomSans(Iterable<? extends X509Extension> values) Contains additional subject alternative name values.addAllDnsNames(Iterable<String> values) Contains only valid, fully-qualified host names.addAllEmailAddresses(Iterable<String> values) Contains only valid RFC 2822 E-mail addresses.addAllIpAddresses(Iterable<String> values) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.addAllUris(Iterable<String> values) Contains only valid RFC 3986 URIs.addCustomSans(int index, X509Extension value) Contains additional subject alternative name values.addCustomSans(int index, X509Extension.Builder builderForValue) Contains additional subject alternative name values.addCustomSans(X509Extension value) Contains additional subject alternative name values.addCustomSans(X509Extension.Builder builderForValue) Contains additional subject alternative name values.Contains additional subject alternative name values.addCustomSansBuilder(int index) Contains additional subject alternative name values.addDnsNames(String value) Contains only valid, fully-qualified host names.addDnsNamesBytes(com.google.protobuf.ByteString value) Contains only valid, fully-qualified host names.addEmailAddresses(String value) Contains only valid RFC 2822 E-mail addresses.addEmailAddressesBytes(com.google.protobuf.ByteString value) Contains only valid RFC 2822 E-mail addresses.addIpAddresses(String value) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.addIpAddressesBytes(com.google.protobuf.ByteString value) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.Contains only valid RFC 3986 URIs.addUrisBytes(com.google.protobuf.ByteString value) Contains only valid RFC 3986 URIs.build()clear()Contains additional subject alternative name values.Contains only valid, fully-qualified host names.Contains only valid RFC 2822 E-mail addresses.Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.Contains only valid RFC 3986 URIs.getCustomSans(int index) Contains additional subject alternative name values.getCustomSansBuilder(int index) Contains additional subject alternative name values.Contains additional subject alternative name values.intContains additional subject alternative name values.Contains additional subject alternative name values.getCustomSansOrBuilder(int index) Contains additional subject alternative name values.List<? extends X509ExtensionOrBuilder>Contains additional subject alternative name values.static final com.google.protobuf.Descriptors.Descriptorcom.google.protobuf.Descriptors.DescriptorgetDnsNames(int index) Contains only valid, fully-qualified host names.com.google.protobuf.ByteStringgetDnsNamesBytes(int index) Contains only valid, fully-qualified host names.intContains only valid, fully-qualified host names.com.google.protobuf.ProtocolStringListContains only valid, fully-qualified host names.getEmailAddresses(int index) Contains only valid RFC 2822 E-mail addresses.com.google.protobuf.ByteStringgetEmailAddressesBytes(int index) Contains only valid RFC 2822 E-mail addresses.intContains only valid RFC 2822 E-mail addresses.com.google.protobuf.ProtocolStringListContains only valid RFC 2822 E-mail addresses.getIpAddresses(int index) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.com.google.protobuf.ByteStringgetIpAddressesBytes(int index) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.intContains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.com.google.protobuf.ProtocolStringListContains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.getUris(int index) Contains only valid RFC 3986 URIs.com.google.protobuf.ByteStringgetUrisBytes(int index) Contains only valid RFC 3986 URIs.intContains only valid RFC 3986 URIs.com.google.protobuf.ProtocolStringListContains only valid RFC 3986 URIs.protected com.google.protobuf.GeneratedMessage.FieldAccessorTablefinal booleanmergeFrom(SubjectAltNames other) mergeFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) mergeFrom(com.google.protobuf.Message other) removeCustomSans(int index) Contains additional subject alternative name values.setCustomSans(int index, X509Extension value) Contains additional subject alternative name values.setCustomSans(int index, X509Extension.Builder builderForValue) Contains additional subject alternative name values.setDnsNames(int index, String value) Contains only valid, fully-qualified host names.setEmailAddresses(int index, String value) Contains only valid RFC 2822 E-mail addresses.setIpAddresses(int index, String value) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.Contains only valid RFC 3986 URIs.Methods inherited from class com.google.protobuf.GeneratedMessage.Builder
addRepeatedField, clearField, clearOneof, clone, getAllFields, getField, getFieldBuilder, getOneofFieldDescriptor, getParentForChildren, getRepeatedField, getRepeatedFieldBuilder, getRepeatedFieldCount, getUnknownFields, getUnknownFieldSetBuilder, hasField, hasOneof, internalGetMapField, internalGetMapFieldReflection, internalGetMutableMapField, internalGetMutableMapFieldReflection, isClean, markClean, mergeUnknownFields, mergeUnknownLengthDelimitedField, mergeUnknownVarintField, newBuilderForField, onBuilt, onChanged, parseUnknownField, setField, setRepeatedField, setUnknownFields, setUnknownFieldSetBuilder, setUnknownFieldsProto3Methods inherited from class com.google.protobuf.AbstractMessage.Builder
findInitializationErrors, getInitializationErrorString, internalMergeFrom, mergeFrom, mergeFrom, mergeFrom, mergeFrom, mergeFrom, mergeFrom, mergeFrom, mergeFrom, mergeFrom, newUninitializedMessageException, toStringMethods inherited from class com.google.protobuf.AbstractMessageLite.Builder
addAll, addAll, mergeDelimitedFrom, mergeDelimitedFrom, mergeFrom, newUninitializedMessageExceptionMethods inherited from class java.lang.Object
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, waitMethods inherited from interface com.google.protobuf.Message.Builder
mergeDelimitedFrom, mergeDelimitedFromMethods inherited from interface com.google.protobuf.MessageLite.Builder
mergeFromMethods inherited from interface com.google.protobuf.MessageOrBuilder
findInitializationErrors, getAllFields, getField, getInitializationErrorString, getOneofFieldDescriptor, getRepeatedField, getRepeatedFieldCount, getUnknownFields, hasField, hasOneof
-
Method Details
-
getDescriptor
public static final com.google.protobuf.Descriptors.Descriptor getDescriptor() -
internalGetFieldAccessorTable
protected com.google.protobuf.GeneratedMessage.FieldAccessorTable internalGetFieldAccessorTable()- Specified by:
internalGetFieldAccessorTablein classcom.google.protobuf.GeneratedMessage.Builder<SubjectAltNames.Builder>
-
clear
- Specified by:
clearin interfacecom.google.protobuf.Message.Builder- Specified by:
clearin interfacecom.google.protobuf.MessageLite.Builder- Overrides:
clearin classcom.google.protobuf.GeneratedMessage.Builder<SubjectAltNames.Builder>
-
getDescriptorForType
public com.google.protobuf.Descriptors.Descriptor getDescriptorForType()- Specified by:
getDescriptorForTypein interfacecom.google.protobuf.Message.Builder- Specified by:
getDescriptorForTypein interfacecom.google.protobuf.MessageOrBuilder- Overrides:
getDescriptorForTypein classcom.google.protobuf.GeneratedMessage.Builder<SubjectAltNames.Builder>
-
getDefaultInstanceForType
- Specified by:
getDefaultInstanceForTypein interfacecom.google.protobuf.MessageLiteOrBuilder- Specified by:
getDefaultInstanceForTypein interfacecom.google.protobuf.MessageOrBuilder
-
build
- Specified by:
buildin interfacecom.google.protobuf.Message.Builder- Specified by:
buildin interfacecom.google.protobuf.MessageLite.Builder
-
buildPartial
- Specified by:
buildPartialin interfacecom.google.protobuf.Message.Builder- Specified by:
buildPartialin interfacecom.google.protobuf.MessageLite.Builder
-
mergeFrom
- Specified by:
mergeFromin interfacecom.google.protobuf.Message.Builder- Overrides:
mergeFromin classcom.google.protobuf.AbstractMessage.Builder<SubjectAltNames.Builder>
-
mergeFrom
-
isInitialized
public final boolean isInitialized()- Specified by:
isInitializedin interfacecom.google.protobuf.MessageLiteOrBuilder- Overrides:
isInitializedin classcom.google.protobuf.GeneratedMessage.Builder<SubjectAltNames.Builder>
-
mergeFrom
public SubjectAltNames.Builder mergeFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException - Specified by:
mergeFromin interfacecom.google.protobuf.Message.Builder- Specified by:
mergeFromin interfacecom.google.protobuf.MessageLite.Builder- Overrides:
mergeFromin classcom.google.protobuf.AbstractMessage.Builder<SubjectAltNames.Builder>- Throws:
IOException
-
getDnsNamesList
public com.google.protobuf.ProtocolStringList getDnsNamesList()Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Specified by:
getDnsNamesListin interfaceSubjectAltNamesOrBuilder- Returns:
- A list containing the dnsNames.
-
getDnsNamesCount
public int getDnsNamesCount()Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Specified by:
getDnsNamesCountin interfaceSubjectAltNamesOrBuilder- Returns:
- The count of dnsNames.
-
getDnsNames
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Specified by:
getDnsNamesin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the element to return.- Returns:
- The dnsNames at the given index.
-
getDnsNamesBytes
public com.google.protobuf.ByteString getDnsNamesBytes(int index) Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Specified by:
getDnsNamesBytesin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the dnsNames at the given index.
-
setDnsNames
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Parameters:
index- The index to set the value at.value- The dnsNames to set.- Returns:
- This builder for chaining.
-
addDnsNames
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Parameters:
value- The dnsNames to add.- Returns:
- This builder for chaining.
-
addAllDnsNames
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Parameters:
values- The dnsNames to add.- Returns:
- This builder for chaining.
-
clearDnsNames
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Returns:
- This builder for chaining.
-
addDnsNamesBytes
Contains only valid, fully-qualified host names.
repeated string dns_names = 1;- Parameters:
value- The bytes of the dnsNames to add.- Returns:
- This builder for chaining.
-
getUrisList
public com.google.protobuf.ProtocolStringList getUrisList()Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Specified by:
getUrisListin interfaceSubjectAltNamesOrBuilder- Returns:
- A list containing the uris.
-
getUrisCount
public int getUrisCount()Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Specified by:
getUrisCountin interfaceSubjectAltNamesOrBuilder- Returns:
- The count of uris.
-
getUris
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Specified by:
getUrisin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the element to return.- Returns:
- The uris at the given index.
-
getUrisBytes
public com.google.protobuf.ByteString getUrisBytes(int index) Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Specified by:
getUrisBytesin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the uris at the given index.
-
setUris
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Parameters:
index- The index to set the value at.value- The uris to set.- Returns:
- This builder for chaining.
-
addUris
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Parameters:
value- The uris to add.- Returns:
- This builder for chaining.
-
addAllUris
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Parameters:
values- The uris to add.- Returns:
- This builder for chaining.
-
clearUris
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Returns:
- This builder for chaining.
-
addUrisBytes
Contains only valid RFC 3986 URIs.
repeated string uris = 2;- Parameters:
value- The bytes of the uris to add.- Returns:
- This builder for chaining.
-
getEmailAddressesList
public com.google.protobuf.ProtocolStringList getEmailAddressesList()Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Specified by:
getEmailAddressesListin interfaceSubjectAltNamesOrBuilder- Returns:
- A list containing the emailAddresses.
-
getEmailAddressesCount
public int getEmailAddressesCount()Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Specified by:
getEmailAddressesCountin interfaceSubjectAltNamesOrBuilder- Returns:
- The count of emailAddresses.
-
getEmailAddresses
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Specified by:
getEmailAddressesin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the element to return.- Returns:
- The emailAddresses at the given index.
-
getEmailAddressesBytes
public com.google.protobuf.ByteString getEmailAddressesBytes(int index) Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Specified by:
getEmailAddressesBytesin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the emailAddresses at the given index.
-
setEmailAddresses
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Parameters:
index- The index to set the value at.value- The emailAddresses to set.- Returns:
- This builder for chaining.
-
addEmailAddresses
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Parameters:
value- The emailAddresses to add.- Returns:
- This builder for chaining.
-
addAllEmailAddresses
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Parameters:
values- The emailAddresses to add.- Returns:
- This builder for chaining.
-
clearEmailAddresses
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Returns:
- This builder for chaining.
-
addEmailAddressesBytes
Contains only valid RFC 2822 E-mail addresses.
repeated string email_addresses = 3;- Parameters:
value- The bytes of the emailAddresses to add.- Returns:
- This builder for chaining.
-
getIpAddressesList
public com.google.protobuf.ProtocolStringList getIpAddressesList()Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Specified by:
getIpAddressesListin interfaceSubjectAltNamesOrBuilder- Returns:
- A list containing the ipAddresses.
-
getIpAddressesCount
public int getIpAddressesCount()Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Specified by:
getIpAddressesCountin interfaceSubjectAltNamesOrBuilder- Returns:
- The count of ipAddresses.
-
getIpAddresses
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Specified by:
getIpAddressesin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the element to return.- Returns:
- The ipAddresses at the given index.
-
getIpAddressesBytes
public com.google.protobuf.ByteString getIpAddressesBytes(int index) Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Specified by:
getIpAddressesBytesin interfaceSubjectAltNamesOrBuilder- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the ipAddresses at the given index.
-
setIpAddresses
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Parameters:
index- The index to set the value at.value- The ipAddresses to set.- Returns:
- This builder for chaining.
-
addIpAddresses
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Parameters:
value- The ipAddresses to add.- Returns:
- This builder for chaining.
-
addAllIpAddresses
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Parameters:
values- The ipAddresses to add.- Returns:
- This builder for chaining.
-
clearIpAddresses
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Returns:
- This builder for chaining.
-
addIpAddressesBytes
Contains only valid 32-bit IPv4 addresses or RFC 4291 IPv6 addresses.
repeated string ip_addresses = 4;- Parameters:
value- The bytes of the ipAddresses to add.- Returns:
- This builder for chaining.
-
getCustomSansList
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;- Specified by:
getCustomSansListin interfaceSubjectAltNamesOrBuilder
-
getCustomSansCount
public int getCustomSansCount()Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;- Specified by:
getCustomSansCountin interfaceSubjectAltNamesOrBuilder
-
getCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;- Specified by:
getCustomSansin interfaceSubjectAltNamesOrBuilder
-
setCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
setCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
addCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
addCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
addCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
addCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
addAllCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
clearCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
removeCustomSans
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
getCustomSansBuilder
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
getCustomSansOrBuilder
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;- Specified by:
getCustomSansOrBuilderin interfaceSubjectAltNamesOrBuilder
-
getCustomSansOrBuilderList
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;- Specified by:
getCustomSansOrBuilderListin interfaceSubjectAltNamesOrBuilder
-
addCustomSansBuilder
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
addCustomSansBuilder
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5; -
getCustomSansBuilderList
Contains additional subject alternative name values. For each custom_san, the `value` field must contain an ASN.1 encoded UTF8String.
repeated .google.cloud.security.privateca.v1.X509Extension custom_sans = 5;
-