Interface RouteOrBuilder

All Superinterfaces:
com.google.protobuf.MessageLiteOrBuilder, com.google.protobuf.MessageOrBuilder
All Known Implementing Classes:
Route, Route.Builder

@Generated public interface RouteOrBuilder extends com.google.protobuf.MessageOrBuilder
  • Method Details

    • getAsPathsList

      List<RouteAsPath> getAsPathsList()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • getAsPaths

      RouteAsPath getAsPaths(int index)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • getAsPathsCount

      int getAsPathsCount()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • getAsPathsOrBuilderList

      List<? extends RouteAsPathOrBuilder> getAsPathsOrBuilderList()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • getAsPathsOrBuilder

      RouteAsPathOrBuilder getAsPathsOrBuilder(int index)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • hasCreationTimestamp

      boolean hasCreationTimestamp()
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Returns:
      Whether the creationTimestamp field is set.
    • getCreationTimestamp

      String getCreationTimestamp()
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Returns:
      The creationTimestamp.
    • getCreationTimestampBytes

      com.google.protobuf.ByteString getCreationTimestampBytes()
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Returns:
      The bytes for creationTimestamp.
    • hasDescription

      boolean hasDescription()
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Returns:
      Whether the description field is set.
    • getDescription

      String getDescription()
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Returns:
      The description.
    • getDescriptionBytes

      com.google.protobuf.ByteString getDescriptionBytes()
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Returns:
      The bytes for description.
    • hasDestRange

      boolean hasDestRange()
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Returns:
      Whether the destRange field is set.
    • getDestRange

      String getDestRange()
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Returns:
      The destRange.
    • getDestRangeBytes

      com.google.protobuf.ByteString getDestRangeBytes()
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Returns:
      The bytes for destRange.
    • hasId

      boolean hasId()
       Output only. [Output Only] The unique identifier for the resource. This identifier is
       defined by the server.
       
      optional uint64 id = 3355;
      Returns:
      Whether the id field is set.
    • getId

      long getId()
       Output only. [Output Only] The unique identifier for the resource. This identifier is
       defined by the server.
       
      optional uint64 id = 3355;
      Returns:
      The id.
    • hasKind

      boolean hasKind()
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Returns:
      Whether the kind field is set.
    • getKind

      String getKind()
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Returns:
      The kind.
    • getKindBytes

      com.google.protobuf.ByteString getKindBytes()
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Returns:
      The bytes for kind.
    • hasName

      boolean hasName()
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Returns:
      Whether the name field is set.
    • getName

      String getName()
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Returns:
      The name.
    • getNameBytes

      com.google.protobuf.ByteString getNameBytes()
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Returns:
      The bytes for name.
    • hasNetwork

      boolean hasNetwork()
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Returns:
      Whether the network field is set.
    • getNetwork

      String getNetwork()
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Returns:
      The network.
    • getNetworkBytes

      com.google.protobuf.ByteString getNetworkBytes()
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Returns:
      The bytes for network.
    • hasNextHopGateway

      boolean hasNextHopGateway()
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Returns:
      Whether the nextHopGateway field is set.
    • getNextHopGateway

      String getNextHopGateway()
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Returns:
      The nextHopGateway.
    • getNextHopGatewayBytes

      com.google.protobuf.ByteString getNextHopGatewayBytes()
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Returns:
      The bytes for nextHopGateway.
    • hasNextHopHub

      boolean hasNextHopHub()
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Returns:
      Whether the nextHopHub field is set.
    • getNextHopHub

      String getNextHopHub()
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Returns:
      The nextHopHub.
    • getNextHopHubBytes

      com.google.protobuf.ByteString getNextHopHubBytes()
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Returns:
      The bytes for nextHopHub.
    • hasNextHopIlb

      boolean hasNextHopIlb()
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Returns:
      Whether the nextHopIlb field is set.
    • getNextHopIlb

      String getNextHopIlb()
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Returns:
      The nextHopIlb.
    • getNextHopIlbBytes

      com.google.protobuf.ByteString getNextHopIlbBytes()
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Returns:
      The bytes for nextHopIlb.
    • hasNextHopInstance

      boolean hasNextHopInstance()
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Returns:
      Whether the nextHopInstance field is set.
    • getNextHopInstance

      String getNextHopInstance()
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Returns:
      The nextHopInstance.
    • getNextHopInstanceBytes

      com.google.protobuf.ByteString getNextHopInstanceBytes()
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Returns:
      The bytes for nextHopInstance.
    • hasNextHopInterRegionCost

      boolean hasNextHopInterRegionCost()
       Output only. [Output only] Internal fixed region-to-region cost that Google Cloud
       calculates based on factors such as network performance, distance, and
       available bandwidth between regions.
       
      optional uint32 next_hop_inter_region_cost = 24442003;
      Returns:
      Whether the nextHopInterRegionCost field is set.
    • getNextHopInterRegionCost

      int getNextHopInterRegionCost()
       Output only. [Output only] Internal fixed region-to-region cost that Google Cloud
       calculates based on factors such as network performance, distance, and
       available bandwidth between regions.
       
      optional uint32 next_hop_inter_region_cost = 24442003;
      Returns:
      The nextHopInterRegionCost.
    • hasNextHopInterconnectAttachment

      boolean hasNextHopInterconnectAttachment()
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Returns:
      Whether the nextHopInterconnectAttachment field is set.
    • getNextHopInterconnectAttachment

      String getNextHopInterconnectAttachment()
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Returns:
      The nextHopInterconnectAttachment.
    • getNextHopInterconnectAttachmentBytes

      com.google.protobuf.ByteString getNextHopInterconnectAttachmentBytes()
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Returns:
      The bytes for nextHopInterconnectAttachment.
    • hasNextHopIp

      boolean hasNextHopIp()
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Returns:
      Whether the nextHopIp field is set.
    • getNextHopIp

      String getNextHopIp()
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Returns:
      The nextHopIp.
    • getNextHopIpBytes

      com.google.protobuf.ByteString getNextHopIpBytes()
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Returns:
      The bytes for nextHopIp.
    • hasNextHopMed

      boolean hasNextHopMed()
       Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates
       the desirability of a particular route in a network.
       
      optional uint32 next_hop_med = 198683530;
      Returns:
      Whether the nextHopMed field is set.
    • getNextHopMed

      int getNextHopMed()
       Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates
       the desirability of a particular route in a network.
       
      optional uint32 next_hop_med = 198683530;
      Returns:
      The nextHopMed.
    • hasNextHopNetwork

      boolean hasNextHopNetwork()
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Returns:
      Whether the nextHopNetwork field is set.
    • getNextHopNetwork

      String getNextHopNetwork()
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Returns:
      The nextHopNetwork.
    • getNextHopNetworkBytes

      com.google.protobuf.ByteString getNextHopNetworkBytes()
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Returns:
      The bytes for nextHopNetwork.
    • hasNextHopOrigin

      boolean hasNextHopOrigin()
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Returns:
      Whether the nextHopOrigin field is set.
    • getNextHopOrigin

      String getNextHopOrigin()
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Returns:
      The nextHopOrigin.
    • getNextHopOriginBytes

      com.google.protobuf.ByteString getNextHopOriginBytes()
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Returns:
      The bytes for nextHopOrigin.
    • hasNextHopPeering

      boolean hasNextHopPeering()
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Returns:
      Whether the nextHopPeering field is set.
    • getNextHopPeering

      String getNextHopPeering()
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Returns:
      The nextHopPeering.
    • getNextHopPeeringBytes

      com.google.protobuf.ByteString getNextHopPeeringBytes()
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Returns:
      The bytes for nextHopPeering.
    • hasNextHopVpnTunnel

      boolean hasNextHopVpnTunnel()
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Returns:
      Whether the nextHopVpnTunnel field is set.
    • getNextHopVpnTunnel

      String getNextHopVpnTunnel()
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Returns:
      The nextHopVpnTunnel.
    • getNextHopVpnTunnelBytes

      com.google.protobuf.ByteString getNextHopVpnTunnelBytes()
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Returns:
      The bytes for nextHopVpnTunnel.
    • hasParams

      boolean hasParams()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
      Returns:
      Whether the params field is set.
    • getParams

      RouteParams getParams()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
      Returns:
      The params.
    • getParamsOrBuilder

      RouteParamsOrBuilder getParamsOrBuilder()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
    • hasPriority

      boolean hasPriority()
       The priority of this route. Priority is used to break ties in cases
       where there is more than one matching route of equal prefix length. In
       cases where multiple routes have equal prefix length, the one with the
       lowest-numbered priority value wins. The default value is `1000`. The
       priority value must be from `0` to `65535`, inclusive.
       
      optional uint32 priority = 445151652;
      Returns:
      Whether the priority field is set.
    • getPriority

      int getPriority()
       The priority of this route. Priority is used to break ties in cases
       where there is more than one matching route of equal prefix length. In
       cases where multiple routes have equal prefix length, the one with the
       lowest-numbered priority value wins. The default value is `1000`. The
       priority value must be from `0` to `65535`, inclusive.
       
      optional uint32 priority = 445151652;
      Returns:
      The priority.
    • hasRouteStatus

      boolean hasRouteStatus()
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Returns:
      Whether the routeStatus field is set.
    • getRouteStatus

      String getRouteStatus()
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Returns:
      The routeStatus.
    • getRouteStatusBytes

      com.google.protobuf.ByteString getRouteStatusBytes()
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Returns:
      The bytes for routeStatus.
    • hasRouteType

      boolean hasRouteType()
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Returns:
      Whether the routeType field is set.
    • getRouteType

      String getRouteType()
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Returns:
      The routeType.
    • getRouteTypeBytes

      com.google.protobuf.ByteString getRouteTypeBytes()
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Returns:
      The bytes for routeType.
    • hasSelfLink

      boolean hasSelfLink()
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Returns:
      Whether the selfLink field is set.
    • getSelfLink

      String getSelfLink()
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Returns:
      The selfLink.
    • getSelfLinkBytes

      com.google.protobuf.ByteString getSelfLinkBytes()
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Returns:
      The bytes for selfLink.
    • getTagsList

      List<String> getTagsList()
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Returns:
      A list containing the tags.
    • getTagsCount

      int getTagsCount()
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Returns:
      The count of tags.
    • getTags

      String getTags(int index)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Parameters:
      index - The index of the element to return.
      Returns:
      The tags at the given index.
    • getTagsBytes

      com.google.protobuf.ByteString getTagsBytes(int index)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Parameters:
      index - The index of the value to return.
      Returns:
      The bytes of the tags at the given index.
    • getWarningsList

      List<Warnings> getWarningsList()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • getWarnings

      Warnings getWarnings(int index)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • getWarningsCount

      int getWarningsCount()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • getWarningsOrBuilderList

      List<? extends WarningsOrBuilder> getWarningsOrBuilderList()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • getWarningsOrBuilder

      WarningsOrBuilder getWarningsOrBuilder(int index)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;