Package com.google.cloud.compute.v1
Class Route
java.lang.Object
com.google.protobuf.AbstractMessageLite
com.google.protobuf.AbstractMessage
com.google.protobuf.GeneratedMessage
com.google.cloud.compute.v1.Route
- All Implemented Interfaces:
RouteOrBuilder,com.google.protobuf.Message,com.google.protobuf.MessageLite,com.google.protobuf.MessageLiteOrBuilder,com.google.protobuf.MessageOrBuilder,Serializable
@Generated
public final class Route
extends com.google.protobuf.GeneratedMessage
implements RouteOrBuilder
Represents a Route resource. A route defines a path from VM instances in the VPC network to a specific destination. This destination can be inside or outside the VPC network. For more information, read theRoutes overview.Protobuf type
google.cloud.compute.v1.Route- See Also:
-
Nested Class Summary
Nested ClassesModifier and TypeClassDescriptionstatic final classRepresents a Route resource.static enumOutput only.static enum[Output only] The status of the route.static enumOutput only.Nested classes/interfaces inherited from class com.google.protobuf.GeneratedMessage
com.google.protobuf.GeneratedMessage.ExtendableBuilder<MessageT extends com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT>,BuilderT extends com.google.protobuf.GeneratedMessage.ExtendableBuilder<MessageT, BuilderT>>, com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT extends com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT>>, com.google.protobuf.GeneratedMessage.ExtendableMessageOrBuilder<MessageT extends com.google.protobuf.GeneratedMessage.ExtendableMessage<MessageT>>, com.google.protobuf.GeneratedMessage.FieldAccessorTable, com.google.protobuf.GeneratedMessage.GeneratedExtension<ContainingT extends com.google.protobuf.Message, T extends Object>, com.google.protobuf.GeneratedMessage.UnusedPrivateParameter Nested classes/interfaces inherited from class com.google.protobuf.AbstractMessage
com.google.protobuf.AbstractMessage.BuilderParentNested classes/interfaces inherited from class com.google.protobuf.AbstractMessageLite
com.google.protobuf.AbstractMessageLite.InternalOneOfEnum -
Field Summary
FieldsModifier and TypeFieldDescriptionstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intstatic final intFields inherited from class com.google.protobuf.GeneratedMessage
alwaysUseFieldBuilders, loggedPre22TypeNames, unknownFieldsFields inherited from class com.google.protobuf.AbstractMessage
memoizedSizeFields inherited from class com.google.protobuf.AbstractMessageLite
memoizedHashCode -
Method Summary
Modifier and TypeMethodDescriptionbooleangetAsPaths(int index) Output only.intOutput only.Output only.getAsPathsOrBuilder(int index) Output only.List<? extends RouteAsPathOrBuilder>Output only.Output only.com.google.protobuf.ByteStringOutput only.static RouteAn optional description of this resource.com.google.protobuf.ByteStringAn optional description of this resource.static final com.google.protobuf.Descriptors.DescriptorThe destination range of outgoing packets that this route applies to.com.google.protobuf.ByteStringThe destination range of outgoing packets that this route applies to.longgetId()Output only.getKind()Output only.com.google.protobuf.ByteStringOutput only.getName()Name of the resource.com.google.protobuf.ByteStringName of the resource.Fully-qualified URL of the network that this route applies to.com.google.protobuf.ByteStringFully-qualified URL of the network that this route applies to.The URL to a gateway that should handle matching packets.com.google.protobuf.ByteStringThe URL to a gateway that should handle matching packets.Output only.com.google.protobuf.ByteStringOutput only.The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule.com.google.protobuf.ByteStringThe URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule.The URL to an instance that should handle matching packets.com.google.protobuf.ByteStringThe URL to an instance that should handle matching packets.Output only.com.google.protobuf.ByteStringOutput only.intOutput only.The network IP address of an instance that should handle matching packets.com.google.protobuf.ByteStringThe network IP address of an instance that should handle matching packets.intOutput only.The URL of the local network if it should handle matching packets.com.google.protobuf.ByteStringThe URL of the local network if it should handle matching packets.Output only.com.google.protobuf.ByteStringOutput only.Output only.com.google.protobuf.ByteStringOutput only.The URL to a VpnTunnel that should handle matching packets.com.google.protobuf.ByteStringThe URL to a VpnTunnel that should handle matching packets.Input only.Input only.com.google.protobuf.Parser<Route>intThe priority of this route.[Output only] The status of the route.com.google.protobuf.ByteString[Output only] The status of the route.Output only.com.google.protobuf.ByteStringOutput only.[Output Only] Server-defined fully-qualified URL for this resource.com.google.protobuf.ByteString[Output Only] Server-defined fully-qualified URL for this resource.intgetTags(int index) A list of instance tags to which this route applies.com.google.protobuf.ByteStringgetTagsBytes(int index) A list of instance tags to which this route applies.intA list of instance tags to which this route applies.com.google.protobuf.ProtocolStringListA list of instance tags to which this route applies.getWarnings(int index) Output only.intOutput only.Output only.getWarningsOrBuilder(int index) Output only.List<? extends WarningsOrBuilder>Output only.booleanOutput only.booleanAn optional description of this resource.booleanThe destination range of outgoing packets that this route applies to.inthashCode()booleanhasId()Output only.booleanhasKind()Output only.booleanhasName()Name of the resource.booleanFully-qualified URL of the network that this route applies to.booleanThe URL to a gateway that should handle matching packets.booleanOutput only.booleanThe URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule.booleanThe URL to an instance that should handle matching packets.booleanOutput only.booleanOutput only.booleanThe network IP address of an instance that should handle matching packets.booleanOutput only.booleanThe URL of the local network if it should handle matching packets.booleanOutput only.booleanOutput only.booleanThe URL to a VpnTunnel that should handle matching packets.booleanInput only.booleanThe priority of this route.boolean[Output only] The status of the route.booleanOutput only.boolean[Output Only] Server-defined fully-qualified URL for this resource.protected com.google.protobuf.GeneratedMessage.FieldAccessorTablefinal booleanstatic Route.Builderstatic Route.BuildernewBuilder(Route prototype) protected Route.BuildernewBuilderForType(com.google.protobuf.AbstractMessage.BuilderParent parent) static RouteparseDelimitedFrom(InputStream input) static RouteparseDelimitedFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) static RouteparseFrom(byte[] data) static RouteparseFrom(byte[] data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) static RouteparseFrom(com.google.protobuf.ByteString data) static RouteparseFrom(com.google.protobuf.ByteString data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) static RouteparseFrom(com.google.protobuf.CodedInputStream input) static RouteparseFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) static RouteparseFrom(InputStream input) static RouteparseFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) static RouteparseFrom(ByteBuffer data) static RouteparseFrom(ByteBuffer data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) static com.google.protobuf.Parser<Route>parser()voidwriteTo(com.google.protobuf.CodedOutputStream output) Methods inherited from class com.google.protobuf.GeneratedMessage
canUseUnsafe, computeStringSize, computeStringSizeNoTag, emptyBooleanList, emptyDoubleList, emptyFloatList, emptyIntList, emptyList, emptyLongList, getAllFields, getDescriptorForType, getField, getOneofFieldDescriptor, getRepeatedField, getRepeatedFieldCount, getUnknownFields, hasField, hasOneof, internalGetMapField, internalGetMapFieldReflection, isStringEmpty, makeExtensionsImmutable, makeMutableCopy, makeMutableCopy, mergeFromAndMakeImmutableInternal, newFileScopedGeneratedExtension, newInstance, newMessageScopedGeneratedExtension, parseDelimitedWithIOException, parseDelimitedWithIOException, parseUnknownField, parseUnknownFieldProto3, parseWithIOException, parseWithIOException, parseWithIOException, parseWithIOException, serializeBooleanMapTo, serializeIntegerMapTo, serializeLongMapTo, serializeStringMapTo, writeReplace, writeString, writeStringNoTagMethods inherited from class com.google.protobuf.AbstractMessage
findInitializationErrors, getInitializationErrorString, hashFields, toStringMethods inherited from class com.google.protobuf.AbstractMessageLite
addAll, checkByteStringIsUtf8, toByteArray, toByteString, writeDelimitedTo, writeToMethods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, waitMethods inherited from interface com.google.protobuf.MessageLite
toByteArray, toByteString, writeDelimitedTo, writeToMethods inherited from interface com.google.protobuf.MessageOrBuilder
findInitializationErrors, getAllFields, getDescriptorForType, getField, getInitializationErrorString, getOneofFieldDescriptor, getRepeatedField, getRepeatedFieldCount, getUnknownFields, hasField, hasOneof
-
Field Details
-
AS_PATHS_FIELD_NUMBER
public static final int AS_PATHS_FIELD_NUMBER- See Also:
-
CREATION_TIMESTAMP_FIELD_NUMBER
public static final int CREATION_TIMESTAMP_FIELD_NUMBER- See Also:
-
DESCRIPTION_FIELD_NUMBER
public static final int DESCRIPTION_FIELD_NUMBER- See Also:
-
DEST_RANGE_FIELD_NUMBER
public static final int DEST_RANGE_FIELD_NUMBER- See Also:
-
ID_FIELD_NUMBER
public static final int ID_FIELD_NUMBER- See Also:
-
KIND_FIELD_NUMBER
public static final int KIND_FIELD_NUMBER- See Also:
-
NAME_FIELD_NUMBER
public static final int NAME_FIELD_NUMBER- See Also:
-
NETWORK_FIELD_NUMBER
public static final int NETWORK_FIELD_NUMBER- See Also:
-
NEXT_HOP_GATEWAY_FIELD_NUMBER
public static final int NEXT_HOP_GATEWAY_FIELD_NUMBER- See Also:
-
NEXT_HOP_HUB_FIELD_NUMBER
public static final int NEXT_HOP_HUB_FIELD_NUMBER- See Also:
-
NEXT_HOP_ILB_FIELD_NUMBER
public static final int NEXT_HOP_ILB_FIELD_NUMBER- See Also:
-
NEXT_HOP_INSTANCE_FIELD_NUMBER
public static final int NEXT_HOP_INSTANCE_FIELD_NUMBER- See Also:
-
NEXT_HOP_INTER_REGION_COST_FIELD_NUMBER
public static final int NEXT_HOP_INTER_REGION_COST_FIELD_NUMBER- See Also:
-
NEXT_HOP_INTERCONNECT_ATTACHMENT_FIELD_NUMBER
public static final int NEXT_HOP_INTERCONNECT_ATTACHMENT_FIELD_NUMBER- See Also:
-
NEXT_HOP_IP_FIELD_NUMBER
public static final int NEXT_HOP_IP_FIELD_NUMBER- See Also:
-
NEXT_HOP_MED_FIELD_NUMBER
public static final int NEXT_HOP_MED_FIELD_NUMBER- See Also:
-
NEXT_HOP_NETWORK_FIELD_NUMBER
public static final int NEXT_HOP_NETWORK_FIELD_NUMBER- See Also:
-
NEXT_HOP_ORIGIN_FIELD_NUMBER
public static final int NEXT_HOP_ORIGIN_FIELD_NUMBER- See Also:
-
NEXT_HOP_PEERING_FIELD_NUMBER
public static final int NEXT_HOP_PEERING_FIELD_NUMBER- See Also:
-
NEXT_HOP_VPN_TUNNEL_FIELD_NUMBER
public static final int NEXT_HOP_VPN_TUNNEL_FIELD_NUMBER- See Also:
-
PARAMS_FIELD_NUMBER
public static final int PARAMS_FIELD_NUMBER- See Also:
-
PRIORITY_FIELD_NUMBER
public static final int PRIORITY_FIELD_NUMBER- See Also:
-
ROUTE_STATUS_FIELD_NUMBER
public static final int ROUTE_STATUS_FIELD_NUMBER- See Also:
-
ROUTE_TYPE_FIELD_NUMBER
public static final int ROUTE_TYPE_FIELD_NUMBER- See Also:
-
SELF_LINK_FIELD_NUMBER
public static final int SELF_LINK_FIELD_NUMBER- See Also:
-
TAGS_FIELD_NUMBER
public static final int TAGS_FIELD_NUMBER- See Also:
-
WARNINGS_FIELD_NUMBER
public static final int WARNINGS_FIELD_NUMBER- See Also:
-
-
Method Details
-
getDescriptor
public static final com.google.protobuf.Descriptors.Descriptor getDescriptor() -
internalGetFieldAccessorTable
protected com.google.protobuf.GeneratedMessage.FieldAccessorTable internalGetFieldAccessorTable()- Specified by:
internalGetFieldAccessorTablein classcom.google.protobuf.GeneratedMessage
-
getAsPathsList
Output only. [Output Only] AS path.
repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;- Specified by:
getAsPathsListin interfaceRouteOrBuilder
-
getAsPathsOrBuilderList
Output only. [Output Only] AS path.
repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;- Specified by:
getAsPathsOrBuilderListin interfaceRouteOrBuilder
-
getAsPathsCount
public int getAsPathsCount()Output only. [Output Only] AS path.
repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;- Specified by:
getAsPathsCountin interfaceRouteOrBuilder
-
getAsPaths
Output only. [Output Only] AS path.
repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;- Specified by:
getAsPathsin interfaceRouteOrBuilder
-
getAsPathsOrBuilder
Output only. [Output Only] AS path.
repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;- Specified by:
getAsPathsOrBuilderin interfaceRouteOrBuilder
-
hasCreationTimestamp
public boolean hasCreationTimestamp()Output only. [Output Only] Creation timestamp inRFC3339 text format.
optional string creation_timestamp = 30525366;- Specified by:
hasCreationTimestampin interfaceRouteOrBuilder- Returns:
- Whether the creationTimestamp field is set.
-
getCreationTimestamp
Output only. [Output Only] Creation timestamp inRFC3339 text format.
optional string creation_timestamp = 30525366;- Specified by:
getCreationTimestampin interfaceRouteOrBuilder- Returns:
- The creationTimestamp.
-
getCreationTimestampBytes
public com.google.protobuf.ByteString getCreationTimestampBytes()Output only. [Output Only] Creation timestamp inRFC3339 text format.
optional string creation_timestamp = 30525366;- Specified by:
getCreationTimestampBytesin interfaceRouteOrBuilder- Returns:
- The bytes for creationTimestamp.
-
hasDescription
public boolean hasDescription()An optional description of this resource. Provide this field when you create the resource.
optional string description = 422937596;- Specified by:
hasDescriptionin interfaceRouteOrBuilder- Returns:
- Whether the description field is set.
-
getDescription
An optional description of this resource. Provide this field when you create the resource.
optional string description = 422937596;- Specified by:
getDescriptionin interfaceRouteOrBuilder- Returns:
- The description.
-
getDescriptionBytes
public com.google.protobuf.ByteString getDescriptionBytes()An optional description of this resource. Provide this field when you create the resource.
optional string description = 422937596;- Specified by:
getDescriptionBytesin interfaceRouteOrBuilder- Returns:
- The bytes for description.
-
hasDestRange
public boolean hasDestRange()The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.
optional string dest_range = 381327712;- Specified by:
hasDestRangein interfaceRouteOrBuilder- Returns:
- Whether the destRange field is set.
-
getDestRange
The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.
optional string dest_range = 381327712;- Specified by:
getDestRangein interfaceRouteOrBuilder- Returns:
- The destRange.
-
getDestRangeBytes
public com.google.protobuf.ByteString getDestRangeBytes()The destination range of outgoing packets that this route applies to. Both IPv4 and IPv6 are supported. Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291 format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952 compressed format.
optional string dest_range = 381327712;- Specified by:
getDestRangeBytesin interfaceRouteOrBuilder- Returns:
- The bytes for destRange.
-
hasId
public boolean hasId()Output only. [Output Only] The unique identifier for the resource. This identifier is defined by the server.
optional uint64 id = 3355;- Specified by:
hasIdin interfaceRouteOrBuilder- Returns:
- Whether the id field is set.
-
getId
public long getId()Output only. [Output Only] The unique identifier for the resource. This identifier is defined by the server.
optional uint64 id = 3355;- Specified by:
getIdin interfaceRouteOrBuilder- Returns:
- The id.
-
hasKind
public boolean hasKind()Output only. [Output Only] Type of this resource. Always compute#routes for Route resources.
optional string kind = 3292052;- Specified by:
hasKindin interfaceRouteOrBuilder- Returns:
- Whether the kind field is set.
-
getKind
Output only. [Output Only] Type of this resource. Always compute#routes for Route resources.
optional string kind = 3292052;- Specified by:
getKindin interfaceRouteOrBuilder- Returns:
- The kind.
-
getKindBytes
public com.google.protobuf.ByteString getKindBytes()Output only. [Output Only] Type of this resource. Always compute#routes for Route resources.
optional string kind = 3292052;- Specified by:
getKindBytesin interfaceRouteOrBuilder- Returns:
- The bytes for kind.
-
hasName
public boolean hasName()Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply withRFC1035. Specifically, the name must be 1-63 characters long and match the regular expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.
optional string name = 3373707;- Specified by:
hasNamein interfaceRouteOrBuilder- Returns:
- Whether the name field is set.
-
getName
Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply withRFC1035. Specifically, the name must be 1-63 characters long and match the regular expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.
optional string name = 3373707;- Specified by:
getNamein interfaceRouteOrBuilder- Returns:
- The name.
-
getNameBytes
public com.google.protobuf.ByteString getNameBytes()Name of the resource. Provided by the client when the resource is created. The name must be 1-63 characters long, and comply withRFC1035. Specifically, the name must be 1-63 characters long and match the regular expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a lowercase letter, and all following characters (except for the last character) must be a dash, lowercase letter, or digit. The last character must be a lowercase letter or digit.
optional string name = 3373707;- Specified by:
getNameBytesin interfaceRouteOrBuilder- Returns:
- The bytes for name.
-
hasNetwork
public boolean hasNetwork()Fully-qualified URL of the network that this route applies to.
optional string network = 232872494;- Specified by:
hasNetworkin interfaceRouteOrBuilder- Returns:
- Whether the network field is set.
-
getNetwork
Fully-qualified URL of the network that this route applies to.
optional string network = 232872494;- Specified by:
getNetworkin interfaceRouteOrBuilder- Returns:
- The network.
-
getNetworkBytes
public com.google.protobuf.ByteString getNetworkBytes()Fully-qualified URL of the network that this route applies to.
optional string network = 232872494;- Specified by:
getNetworkBytesin interfaceRouteOrBuilder- Returns:
- The bytes for network.
-
hasNextHopGateway
public boolean hasNextHopGateway()The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/project/global/gateways/default-internet-gateway
optional string next_hop_gateway = 377175298;- Specified by:
hasNextHopGatewayin interfaceRouteOrBuilder- Returns:
- Whether the nextHopGateway field is set.
-
getNextHopGateway
The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/project/global/gateways/default-internet-gateway
optional string next_hop_gateway = 377175298;- Specified by:
getNextHopGatewayin interfaceRouteOrBuilder- Returns:
- The nextHopGateway.
-
getNextHopGatewayBytes
public com.google.protobuf.ByteString getNextHopGatewayBytes()The URL to a gateway that should handle matching packets. You can only specify the internet gateway using a full or partial valid URL: projects/project/global/gateways/default-internet-gateway
optional string next_hop_gateway = 377175298;- Specified by:
getNextHopGatewayBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopGateway.
-
hasNextHopHub
public boolean hasNextHopHub()Output only. [Output Only] The full resource name of the Network Connectivity Center hub that will handle matching packets.
optional string next_hop_hub = 198679219;- Specified by:
hasNextHopHubin interfaceRouteOrBuilder- Returns:
- Whether the nextHopHub field is set.
-
getNextHopHub
Output only. [Output Only] The full resource name of the Network Connectivity Center hub that will handle matching packets.
optional string next_hop_hub = 198679219;- Specified by:
getNextHopHubin interfaceRouteOrBuilder- Returns:
- The nextHopHub.
-
getNextHopHubBytes
public com.google.protobuf.ByteString getNextHopHubBytes()Output only. [Output Only] The full resource name of the Network Connectivity Center hub that will handle matching packets.
optional string next_hop_hub = 198679219;- Specified by:
getNextHopHubBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopHub.
-
hasNextHopIlb
public boolean hasNextHopIlb()The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRule If an IP address is provided, must specify an IPv4 address in dot-decimal notation or an IPv6 address in RFC 4291 format. For example, the following are all valid IP addresses: - 10.128.0.56 - 2001:db8::2d9:51:0:0 - 2001:db8:0:0:2d9:51:0:0 IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
optional string next_hop_ilb = 198679901;- Specified by:
hasNextHopIlbin interfaceRouteOrBuilder- Returns:
- Whether the nextHopIlb field is set.
-
getNextHopIlb
The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRule If an IP address is provided, must specify an IPv4 address in dot-decimal notation or an IPv6 address in RFC 4291 format. For example, the following are all valid IP addresses: - 10.128.0.56 - 2001:db8::2d9:51:0:0 - 2001:db8:0:0:2d9:51:0:0 IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
optional string next_hop_ilb = 198679901;- Specified by:
getNextHopIlbin interfaceRouteOrBuilder- Returns:
- The nextHopIlb.
-
getNextHopIlbBytes
public com.google.protobuf.ByteString getNextHopIlbBytes()The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching packets or the IP address of the forwarding Rule. For example, the following are all valid URLs: - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule - regions/region/forwardingRules/forwardingRule If an IP address is provided, must specify an IPv4 address in dot-decimal notation or an IPv6 address in RFC 4291 format. For example, the following are all valid IP addresses: - 10.128.0.56 - 2001:db8::2d9:51:0:0 - 2001:db8:0:0:2d9:51:0:0 IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
optional string next_hop_ilb = 198679901;- Specified by:
getNextHopIlbBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopIlb.
-
hasNextHopInstance
public boolean hasNextHopInstance()The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
optional string next_hop_instance = 393508247;- Specified by:
hasNextHopInstancein interfaceRouteOrBuilder- Returns:
- Whether the nextHopInstance field is set.
-
getNextHopInstance
The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
optional string next_hop_instance = 393508247;- Specified by:
getNextHopInstancein interfaceRouteOrBuilder- Returns:
- The nextHopInstance.
-
getNextHopInstanceBytes
public com.google.protobuf.ByteString getNextHopInstanceBytes()The URL to an instance that should handle matching packets. You can specify this as a full or partial URL. For example: https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
optional string next_hop_instance = 393508247;- Specified by:
getNextHopInstanceBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopInstance.
-
hasNextHopInterRegionCost
public boolean hasNextHopInterRegionCost()Output only. [Output only] Internal fixed region-to-region cost that Google Cloud calculates based on factors such as network performance, distance, and available bandwidth between regions.
optional uint32 next_hop_inter_region_cost = 24442003;- Specified by:
hasNextHopInterRegionCostin interfaceRouteOrBuilder- Returns:
- Whether the nextHopInterRegionCost field is set.
-
getNextHopInterRegionCost
public int getNextHopInterRegionCost()Output only. [Output only] Internal fixed region-to-region cost that Google Cloud calculates based on factors such as network performance, distance, and available bandwidth between regions.
optional uint32 next_hop_inter_region_cost = 24442003;- Specified by:
getNextHopInterRegionCostin interfaceRouteOrBuilder- Returns:
- The nextHopInterRegionCost.
-
hasNextHopInterconnectAttachment
public boolean hasNextHopInterconnectAttachment()Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop for the route. This field will only be populated for dynamic routes generated by Cloud Router with a linked interconnectAttachment or the static route generated by each L2 Interconnect Attachment.
optional string next_hop_interconnect_attachment = 226852914;- Specified by:
hasNextHopInterconnectAttachmentin interfaceRouteOrBuilder- Returns:
- Whether the nextHopInterconnectAttachment field is set.
-
getNextHopInterconnectAttachment
Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop for the route. This field will only be populated for dynamic routes generated by Cloud Router with a linked interconnectAttachment or the static route generated by each L2 Interconnect Attachment.
optional string next_hop_interconnect_attachment = 226852914;- Specified by:
getNextHopInterconnectAttachmentin interfaceRouteOrBuilder- Returns:
- The nextHopInterconnectAttachment.
-
getNextHopInterconnectAttachmentBytes
public com.google.protobuf.ByteString getNextHopInterconnectAttachmentBytes()Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop for the route. This field will only be populated for dynamic routes generated by Cloud Router with a linked interconnectAttachment or the static route generated by each L2 Interconnect Attachment.
optional string next_hop_interconnect_attachment = 226852914;- Specified by:
getNextHopInterconnectAttachmentBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopInterconnectAttachment.
-
hasNextHopIp
public boolean hasNextHopIp()The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
optional string next_hop_ip = 110319529;- Specified by:
hasNextHopIpin interfaceRouteOrBuilder- Returns:
- Whether the nextHopIp field is set.
-
getNextHopIp
The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
optional string next_hop_ip = 110319529;- Specified by:
getNextHopIpin interfaceRouteOrBuilder- Returns:
- The nextHopIp.
-
getNextHopIpBytes
public com.google.protobuf.ByteString getNextHopIpBytes()The network IP address of an instance that should handle matching packets. Both IPv6 address and IPv4 addresses are supported. Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or 2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952 compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
optional string next_hop_ip = 110319529;- Specified by:
getNextHopIpBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopIp.
-
hasNextHopMed
public boolean hasNextHopMed()Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates the desirability of a particular route in a network.
optional uint32 next_hop_med = 198683530;- Specified by:
hasNextHopMedin interfaceRouteOrBuilder- Returns:
- Whether the nextHopMed field is set.
-
getNextHopMed
public int getNextHopMed()Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates the desirability of a particular route in a network.
optional uint32 next_hop_med = 198683530;- Specified by:
getNextHopMedin interfaceRouteOrBuilder- Returns:
- The nextHopMed.
-
hasNextHopNetwork
public boolean hasNextHopNetwork()The URL of the local network if it should handle matching packets.
optional string next_hop_network = 262295788;- Specified by:
hasNextHopNetworkin interfaceRouteOrBuilder- Returns:
- Whether the nextHopNetwork field is set.
-
getNextHopNetwork
The URL of the local network if it should handle matching packets.
optional string next_hop_network = 262295788;- Specified by:
getNextHopNetworkin interfaceRouteOrBuilder- Returns:
- The nextHopNetwork.
-
getNextHopNetworkBytes
public com.google.protobuf.ByteString getNextHopNetworkBytes()The URL of the local network if it should handle matching packets.
optional string next_hop_network = 262295788;- Specified by:
getNextHopNetworkBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopNetwork.
-
hasNextHopOrigin
public boolean hasNextHopOrigin()Output only. [Output Only] Indicates the origin of the route. Can be IGP (Interior Gateway Protocol), EGP (Exterior Gateway Protocol), or INCOMPLETE. Check the NextHopOrigin enum for the list of possible values.
optional string next_hop_origin = 48752808;- Specified by:
hasNextHopOriginin interfaceRouteOrBuilder- Returns:
- Whether the nextHopOrigin field is set.
-
getNextHopOrigin
Output only. [Output Only] Indicates the origin of the route. Can be IGP (Interior Gateway Protocol), EGP (Exterior Gateway Protocol), or INCOMPLETE. Check the NextHopOrigin enum for the list of possible values.
optional string next_hop_origin = 48752808;- Specified by:
getNextHopOriginin interfaceRouteOrBuilder- Returns:
- The nextHopOrigin.
-
getNextHopOriginBytes
public com.google.protobuf.ByteString getNextHopOriginBytes()Output only. [Output Only] Indicates the origin of the route. Can be IGP (Interior Gateway Protocol), EGP (Exterior Gateway Protocol), or INCOMPLETE. Check the NextHopOrigin enum for the list of possible values.
optional string next_hop_origin = 48752808;- Specified by:
getNextHopOriginBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopOrigin.
-
hasNextHopPeering
public boolean hasNextHopPeering()Output only. [Output Only] The network peering name that should handle matching packets, which should conform to RFC1035.
optional string next_hop_peering = 412682750;- Specified by:
hasNextHopPeeringin interfaceRouteOrBuilder- Returns:
- Whether the nextHopPeering field is set.
-
getNextHopPeering
Output only. [Output Only] The network peering name that should handle matching packets, which should conform to RFC1035.
optional string next_hop_peering = 412682750;- Specified by:
getNextHopPeeringin interfaceRouteOrBuilder- Returns:
- The nextHopPeering.
-
getNextHopPeeringBytes
public com.google.protobuf.ByteString getNextHopPeeringBytes()Output only. [Output Only] The network peering name that should handle matching packets, which should conform to RFC1035.
optional string next_hop_peering = 412682750;- Specified by:
getNextHopPeeringBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopPeering.
-
hasNextHopVpnTunnel
public boolean hasNextHopVpnTunnel()The URL to a VpnTunnel that should handle matching packets.
optional string next_hop_vpn_tunnel = 519844501;- Specified by:
hasNextHopVpnTunnelin interfaceRouteOrBuilder- Returns:
- Whether the nextHopVpnTunnel field is set.
-
getNextHopVpnTunnel
The URL to a VpnTunnel that should handle matching packets.
optional string next_hop_vpn_tunnel = 519844501;- Specified by:
getNextHopVpnTunnelin interfaceRouteOrBuilder- Returns:
- The nextHopVpnTunnel.
-
getNextHopVpnTunnelBytes
public com.google.protobuf.ByteString getNextHopVpnTunnelBytes()The URL to a VpnTunnel that should handle matching packets.
optional string next_hop_vpn_tunnel = 519844501;- Specified by:
getNextHopVpnTunnelBytesin interfaceRouteOrBuilder- Returns:
- The bytes for nextHopVpnTunnel.
-
hasParams
public boolean hasParams()Input only. [Input Only] Additional params passed with the request, but not persisted as part of resource payload.
optional .google.cloud.compute.v1.RouteParams params = 78313862;- Specified by:
hasParamsin interfaceRouteOrBuilder- Returns:
- Whether the params field is set.
-
getParams
Input only. [Input Only] Additional params passed with the request, but not persisted as part of resource payload.
optional .google.cloud.compute.v1.RouteParams params = 78313862;- Specified by:
getParamsin interfaceRouteOrBuilder- Returns:
- The params.
-
getParamsOrBuilder
Input only. [Input Only] Additional params passed with the request, but not persisted as part of resource payload.
optional .google.cloud.compute.v1.RouteParams params = 78313862;- Specified by:
getParamsOrBuilderin interfaceRouteOrBuilder
-
hasPriority
public boolean hasPriority()The priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is `1000`. The priority value must be from `0` to `65535`, inclusive.
optional uint32 priority = 445151652;- Specified by:
hasPriorityin interfaceRouteOrBuilder- Returns:
- Whether the priority field is set.
-
getPriority
public int getPriority()The priority of this route. Priority is used to break ties in cases where there is more than one matching route of equal prefix length. In cases where multiple routes have equal prefix length, the one with the lowest-numbered priority value wins. The default value is `1000`. The priority value must be from `0` to `65535`, inclusive.
optional uint32 priority = 445151652;- Specified by:
getPriorityin interfaceRouteOrBuilder- Returns:
- The priority.
-
hasRouteStatus
public boolean hasRouteStatus()[Output only] The status of the route. This status applies to dynamic routes learned by Cloud Routers. It is also applicable to routes undergoing migration. Check the RouteStatus enum for the list of possible values.
optional string route_status = 418162344;- Specified by:
hasRouteStatusin interfaceRouteOrBuilder- Returns:
- Whether the routeStatus field is set.
-
getRouteStatus
[Output only] The status of the route. This status applies to dynamic routes learned by Cloud Routers. It is also applicable to routes undergoing migration. Check the RouteStatus enum for the list of possible values.
optional string route_status = 418162344;- Specified by:
getRouteStatusin interfaceRouteOrBuilder- Returns:
- The routeStatus.
-
getRouteStatusBytes
public com.google.protobuf.ByteString getRouteStatusBytes()[Output only] The status of the route. This status applies to dynamic routes learned by Cloud Routers. It is also applicable to routes undergoing migration. Check the RouteStatus enum for the list of possible values.
optional string route_status = 418162344;- Specified by:
getRouteStatusBytesin interfaceRouteOrBuilder- Returns:
- The bytes for routeStatus.
-
hasRouteType
public boolean hasRouteType()Output only. [Output Only] The type of this route, which can be one of the following values: - 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers - 'SUBNET' for a route from a subnet of the VPC - 'BGP' for a route learned from a BGP peer of this router - 'STATIC' for a static route Check the RouteType enum for the list of possible values.
optional string route_type = 375888752;- Specified by:
hasRouteTypein interfaceRouteOrBuilder- Returns:
- Whether the routeType field is set.
-
getRouteType
Output only. [Output Only] The type of this route, which can be one of the following values: - 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers - 'SUBNET' for a route from a subnet of the VPC - 'BGP' for a route learned from a BGP peer of this router - 'STATIC' for a static route Check the RouteType enum for the list of possible values.
optional string route_type = 375888752;- Specified by:
getRouteTypein interfaceRouteOrBuilder- Returns:
- The routeType.
-
getRouteTypeBytes
public com.google.protobuf.ByteString getRouteTypeBytes()Output only. [Output Only] The type of this route, which can be one of the following values: - 'TRANSIT' for a transit route that this router learned from another Cloud Router and will readvertise to one of its BGP peers - 'SUBNET' for a route from a subnet of the VPC - 'BGP' for a route learned from a BGP peer of this router - 'STATIC' for a static route Check the RouteType enum for the list of possible values.
optional string route_type = 375888752;- Specified by:
getRouteTypeBytesin interfaceRouteOrBuilder- Returns:
- The bytes for routeType.
-
hasSelfLink
public boolean hasSelfLink()[Output Only] Server-defined fully-qualified URL for this resource.
optional string self_link = 456214797;- Specified by:
hasSelfLinkin interfaceRouteOrBuilder- Returns:
- Whether the selfLink field is set.
-
getSelfLink
[Output Only] Server-defined fully-qualified URL for this resource.
optional string self_link = 456214797;- Specified by:
getSelfLinkin interfaceRouteOrBuilder- Returns:
- The selfLink.
-
getSelfLinkBytes
public com.google.protobuf.ByteString getSelfLinkBytes()[Output Only] Server-defined fully-qualified URL for this resource.
optional string self_link = 456214797;- Specified by:
getSelfLinkBytesin interfaceRouteOrBuilder- Returns:
- The bytes for selfLink.
-
getTagsList
public com.google.protobuf.ProtocolStringList getTagsList()A list of instance tags to which this route applies.
repeated string tags = 3552281;- Specified by:
getTagsListin interfaceRouteOrBuilder- Returns:
- A list containing the tags.
-
getTagsCount
public int getTagsCount()A list of instance tags to which this route applies.
repeated string tags = 3552281;- Specified by:
getTagsCountin interfaceRouteOrBuilder- Returns:
- The count of tags.
-
getTags
A list of instance tags to which this route applies.
repeated string tags = 3552281;- Specified by:
getTagsin interfaceRouteOrBuilder- Parameters:
index- The index of the element to return.- Returns:
- The tags at the given index.
-
getTagsBytes
public com.google.protobuf.ByteString getTagsBytes(int index) A list of instance tags to which this route applies.
repeated string tags = 3552281;- Specified by:
getTagsBytesin interfaceRouteOrBuilder- Parameters:
index- The index of the value to return.- Returns:
- The bytes of the tags at the given index.
-
getWarningsList
Output only. [Output Only] If potential misconfigurations are detected for this route, this field will be populated with warning messages.
repeated .google.cloud.compute.v1.Warnings warnings = 498091095;- Specified by:
getWarningsListin interfaceRouteOrBuilder
-
getWarningsOrBuilderList
Output only. [Output Only] If potential misconfigurations are detected for this route, this field will be populated with warning messages.
repeated .google.cloud.compute.v1.Warnings warnings = 498091095;- Specified by:
getWarningsOrBuilderListin interfaceRouteOrBuilder
-
getWarningsCount
public int getWarningsCount()Output only. [Output Only] If potential misconfigurations are detected for this route, this field will be populated with warning messages.
repeated .google.cloud.compute.v1.Warnings warnings = 498091095;- Specified by:
getWarningsCountin interfaceRouteOrBuilder
-
getWarnings
Output only. [Output Only] If potential misconfigurations are detected for this route, this field will be populated with warning messages.
repeated .google.cloud.compute.v1.Warnings warnings = 498091095;- Specified by:
getWarningsin interfaceRouteOrBuilder
-
getWarningsOrBuilder
Output only. [Output Only] If potential misconfigurations are detected for this route, this field will be populated with warning messages.
repeated .google.cloud.compute.v1.Warnings warnings = 498091095;- Specified by:
getWarningsOrBuilderin interfaceRouteOrBuilder
-
isInitialized
public final boolean isInitialized()- Specified by:
isInitializedin interfacecom.google.protobuf.MessageLiteOrBuilder- Overrides:
isInitializedin classcom.google.protobuf.GeneratedMessage
-
writeTo
- Specified by:
writeToin interfacecom.google.protobuf.MessageLite- Overrides:
writeToin classcom.google.protobuf.GeneratedMessage- Throws:
IOException
-
getSerializedSize
public int getSerializedSize()- Specified by:
getSerializedSizein interfacecom.google.protobuf.MessageLite- Overrides:
getSerializedSizein classcom.google.protobuf.GeneratedMessage
-
equals
- Specified by:
equalsin interfacecom.google.protobuf.Message- Overrides:
equalsin classcom.google.protobuf.AbstractMessage
-
hashCode
public int hashCode()- Specified by:
hashCodein interfacecom.google.protobuf.Message- Overrides:
hashCodein classcom.google.protobuf.AbstractMessage
-
parseFrom
public static Route parseFrom(ByteBuffer data) throws com.google.protobuf.InvalidProtocolBufferException - Throws:
com.google.protobuf.InvalidProtocolBufferException
-
parseFrom
public static Route parseFrom(ByteBuffer data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws com.google.protobuf.InvalidProtocolBufferException - Throws:
com.google.protobuf.InvalidProtocolBufferException
-
parseFrom
public static Route parseFrom(com.google.protobuf.ByteString data) throws com.google.protobuf.InvalidProtocolBufferException - Throws:
com.google.protobuf.InvalidProtocolBufferException
-
parseFrom
public static Route parseFrom(com.google.protobuf.ByteString data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws com.google.protobuf.InvalidProtocolBufferException - Throws:
com.google.protobuf.InvalidProtocolBufferException
-
parseFrom
public static Route parseFrom(byte[] data) throws com.google.protobuf.InvalidProtocolBufferException - Throws:
com.google.protobuf.InvalidProtocolBufferException
-
parseFrom
public static Route parseFrom(byte[] data, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws com.google.protobuf.InvalidProtocolBufferException - Throws:
com.google.protobuf.InvalidProtocolBufferException
-
parseFrom
- Throws:
IOException
-
parseFrom
public static Route parseFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException - Throws:
IOException
-
parseDelimitedFrom
- Throws:
IOException
-
parseDelimitedFrom
public static Route parseDelimitedFrom(InputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException - Throws:
IOException
-
parseFrom
- Throws:
IOException
-
parseFrom
public static Route parseFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException - Throws:
IOException
-
newBuilderForType
- Specified by:
newBuilderForTypein interfacecom.google.protobuf.Message- Specified by:
newBuilderForTypein interfacecom.google.protobuf.MessageLite
-
newBuilder
-
newBuilder
-
toBuilder
- Specified by:
toBuilderin interfacecom.google.protobuf.Message- Specified by:
toBuilderin interfacecom.google.protobuf.MessageLite
-
newBuilderForType
- Overrides:
newBuilderForTypein classcom.google.protobuf.AbstractMessage
-
getDefaultInstance
-
parser
-
getParserForType
- Specified by:
getParserForTypein interfacecom.google.protobuf.Message- Specified by:
getParserForTypein interfacecom.google.protobuf.MessageLite- Overrides:
getParserForTypein classcom.google.protobuf.GeneratedMessage
-
getDefaultInstanceForType
- Specified by:
getDefaultInstanceForTypein interfacecom.google.protobuf.MessageLiteOrBuilder- Specified by:
getDefaultInstanceForTypein interfacecom.google.protobuf.MessageOrBuilder
-