Class Route.Builder

java.lang.Object
com.google.protobuf.AbstractMessageLite.Builder
com.google.protobuf.AbstractMessage.Builder<BuilderT>
com.google.protobuf.GeneratedMessage.Builder<Route.Builder>
com.google.cloud.compute.v1.Route.Builder
All Implemented Interfaces:
RouteOrBuilder, com.google.protobuf.Message.Builder, com.google.protobuf.MessageLite.Builder, com.google.protobuf.MessageLiteOrBuilder, com.google.protobuf.MessageOrBuilder, Cloneable
Enclosing class:
Route

public static final class Route.Builder extends com.google.protobuf.GeneratedMessage.Builder<Route.Builder> implements RouteOrBuilder
 Represents a Route resource.

 A route defines a path from VM instances in the VPC network to a specific
 destination. This destination can be inside or outside the VPC network.
 For more information, read theRoutes overview.
 
Protobuf type google.cloud.compute.v1.Route
  • Method Details

    • getDescriptor

      public static final com.google.protobuf.Descriptors.Descriptor getDescriptor()
    • internalGetFieldAccessorTable

      protected com.google.protobuf.GeneratedMessage.FieldAccessorTable internalGetFieldAccessorTable()
      Specified by:
      internalGetFieldAccessorTable in class com.google.protobuf.GeneratedMessage.Builder<Route.Builder>
    • clear

      public Route.Builder clear()
      Specified by:
      clear in interface com.google.protobuf.Message.Builder
      Specified by:
      clear in interface com.google.protobuf.MessageLite.Builder
      Overrides:
      clear in class com.google.protobuf.GeneratedMessage.Builder<Route.Builder>
    • getDescriptorForType

      public com.google.protobuf.Descriptors.Descriptor getDescriptorForType()
      Specified by:
      getDescriptorForType in interface com.google.protobuf.Message.Builder
      Specified by:
      getDescriptorForType in interface com.google.protobuf.MessageOrBuilder
      Overrides:
      getDescriptorForType in class com.google.protobuf.GeneratedMessage.Builder<Route.Builder>
    • getDefaultInstanceForType

      public Route getDefaultInstanceForType()
      Specified by:
      getDefaultInstanceForType in interface com.google.protobuf.MessageLiteOrBuilder
      Specified by:
      getDefaultInstanceForType in interface com.google.protobuf.MessageOrBuilder
    • build

      public Route build()
      Specified by:
      build in interface com.google.protobuf.Message.Builder
      Specified by:
      build in interface com.google.protobuf.MessageLite.Builder
    • buildPartial

      public Route buildPartial()
      Specified by:
      buildPartial in interface com.google.protobuf.Message.Builder
      Specified by:
      buildPartial in interface com.google.protobuf.MessageLite.Builder
    • mergeFrom

      public Route.Builder mergeFrom(com.google.protobuf.Message other)
      Specified by:
      mergeFrom in interface com.google.protobuf.Message.Builder
      Overrides:
      mergeFrom in class com.google.protobuf.AbstractMessage.Builder<Route.Builder>
    • mergeFrom

      public Route.Builder mergeFrom(Route other)
    • isInitialized

      public final boolean isInitialized()
      Specified by:
      isInitialized in interface com.google.protobuf.MessageLiteOrBuilder
      Overrides:
      isInitialized in class com.google.protobuf.GeneratedMessage.Builder<Route.Builder>
    • mergeFrom

      public Route.Builder mergeFrom(com.google.protobuf.CodedInputStream input, com.google.protobuf.ExtensionRegistryLite extensionRegistry) throws IOException
      Specified by:
      mergeFrom in interface com.google.protobuf.Message.Builder
      Specified by:
      mergeFrom in interface com.google.protobuf.MessageLite.Builder
      Overrides:
      mergeFrom in class com.google.protobuf.AbstractMessage.Builder<Route.Builder>
      Throws:
      IOException
    • getAsPathsList

      public List<RouteAsPath> getAsPathsList()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
      Specified by:
      getAsPathsList in interface RouteOrBuilder
    • getAsPathsCount

      public int getAsPathsCount()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
      Specified by:
      getAsPathsCount in interface RouteOrBuilder
    • getAsPaths

      public RouteAsPath getAsPaths(int index)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
      Specified by:
      getAsPaths in interface RouteOrBuilder
    • setAsPaths

      public Route.Builder setAsPaths(int index, RouteAsPath value)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • setAsPaths

      public Route.Builder setAsPaths(int index, RouteAsPath.Builder builderForValue)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • addAsPaths

      public Route.Builder addAsPaths(RouteAsPath value)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • addAsPaths

      public Route.Builder addAsPaths(int index, RouteAsPath value)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • addAsPaths

      public Route.Builder addAsPaths(RouteAsPath.Builder builderForValue)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • addAsPaths

      public Route.Builder addAsPaths(int index, RouteAsPath.Builder builderForValue)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • addAllAsPaths

      public Route.Builder addAllAsPaths(Iterable<? extends RouteAsPath> values)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • clearAsPaths

      public Route.Builder clearAsPaths()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • removeAsPaths

      public Route.Builder removeAsPaths(int index)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • getAsPathsBuilder

      public RouteAsPath.Builder getAsPathsBuilder(int index)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • getAsPathsOrBuilder

      public RouteAsPathOrBuilder getAsPathsOrBuilder(int index)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
      Specified by:
      getAsPathsOrBuilder in interface RouteOrBuilder
    • getAsPathsOrBuilderList

      public List<? extends RouteAsPathOrBuilder> getAsPathsOrBuilderList()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
      Specified by:
      getAsPathsOrBuilderList in interface RouteOrBuilder
    • addAsPathsBuilder

      public RouteAsPath.Builder addAsPathsBuilder()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • addAsPathsBuilder

      public RouteAsPath.Builder addAsPathsBuilder(int index)
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • getAsPathsBuilderList

      public List<RouteAsPath.Builder> getAsPathsBuilderList()
       Output only. [Output Only] AS path.
       
      repeated .google.cloud.compute.v1.RouteAsPath as_paths = 137568929;
    • hasCreationTimestamp

      public boolean hasCreationTimestamp()
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Specified by:
      hasCreationTimestamp in interface RouteOrBuilder
      Returns:
      Whether the creationTimestamp field is set.
    • getCreationTimestamp

      public String getCreationTimestamp()
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Specified by:
      getCreationTimestamp in interface RouteOrBuilder
      Returns:
      The creationTimestamp.
    • getCreationTimestampBytes

      public com.google.protobuf.ByteString getCreationTimestampBytes()
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Specified by:
      getCreationTimestampBytes in interface RouteOrBuilder
      Returns:
      The bytes for creationTimestamp.
    • setCreationTimestamp

      public Route.Builder setCreationTimestamp(String value)
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Parameters:
      value - The creationTimestamp to set.
      Returns:
      This builder for chaining.
    • clearCreationTimestamp

      public Route.Builder clearCreationTimestamp()
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Returns:
      This builder for chaining.
    • setCreationTimestampBytes

      public Route.Builder setCreationTimestampBytes(com.google.protobuf.ByteString value)
       Output only. [Output Only] Creation timestamp inRFC3339
       text format.
       
      optional string creation_timestamp = 30525366;
      Parameters:
      value - The bytes for creationTimestamp to set.
      Returns:
      This builder for chaining.
    • hasDescription

      public boolean hasDescription()
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Specified by:
      hasDescription in interface RouteOrBuilder
      Returns:
      Whether the description field is set.
    • getDescription

      public String getDescription()
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Specified by:
      getDescription in interface RouteOrBuilder
      Returns:
      The description.
    • getDescriptionBytes

      public com.google.protobuf.ByteString getDescriptionBytes()
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Specified by:
      getDescriptionBytes in interface RouteOrBuilder
      Returns:
      The bytes for description.
    • setDescription

      public Route.Builder setDescription(String value)
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Parameters:
      value - The description to set.
      Returns:
      This builder for chaining.
    • clearDescription

      public Route.Builder clearDescription()
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Returns:
      This builder for chaining.
    • setDescriptionBytes

      public Route.Builder setDescriptionBytes(com.google.protobuf.ByteString value)
       An optional description of this resource. Provide this field when you
       create the resource.
       
      optional string description = 422937596;
      Parameters:
      value - The bytes for description to set.
      Returns:
      This builder for chaining.
    • hasDestRange

      public boolean hasDestRange()
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Specified by:
      hasDestRange in interface RouteOrBuilder
      Returns:
      Whether the destRange field is set.
    • getDestRange

      public String getDestRange()
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Specified by:
      getDestRange in interface RouteOrBuilder
      Returns:
      The destRange.
    • getDestRangeBytes

      public com.google.protobuf.ByteString getDestRangeBytes()
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Specified by:
      getDestRangeBytes in interface RouteOrBuilder
      Returns:
      The bytes for destRange.
    • setDestRange

      public Route.Builder setDestRange(String value)
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Parameters:
      value - The destRange to set.
      Returns:
      This builder for chaining.
    • clearDestRange

      public Route.Builder clearDestRange()
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Returns:
      This builder for chaining.
    • setDestRangeBytes

      public Route.Builder setDestRangeBytes(com.google.protobuf.ByteString value)
       The destination range of outgoing packets that this route applies to. Both
       IPv4 and IPv6 are supported.
       Must specify an IPv4 range (e.g. 192.0.2.0/24) or an IPv6 range in RFC 4291
       format (e.g. 2001:db8::/32). IPv6 range will be displayed using RFC 5952
       compressed format.
       
      optional string dest_range = 381327712;
      Parameters:
      value - The bytes for destRange to set.
      Returns:
      This builder for chaining.
    • hasId

      public boolean hasId()
       Output only. [Output Only] The unique identifier for the resource. This identifier is
       defined by the server.
       
      optional uint64 id = 3355;
      Specified by:
      hasId in interface RouteOrBuilder
      Returns:
      Whether the id field is set.
    • getId

      public long getId()
       Output only. [Output Only] The unique identifier for the resource. This identifier is
       defined by the server.
       
      optional uint64 id = 3355;
      Specified by:
      getId in interface RouteOrBuilder
      Returns:
      The id.
    • setId

      public Route.Builder setId(long value)
       Output only. [Output Only] The unique identifier for the resource. This identifier is
       defined by the server.
       
      optional uint64 id = 3355;
      Parameters:
      value - The id to set.
      Returns:
      This builder for chaining.
    • clearId

      public Route.Builder clearId()
       Output only. [Output Only] The unique identifier for the resource. This identifier is
       defined by the server.
       
      optional uint64 id = 3355;
      Returns:
      This builder for chaining.
    • hasKind

      public boolean hasKind()
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Specified by:
      hasKind in interface RouteOrBuilder
      Returns:
      Whether the kind field is set.
    • getKind

      public String getKind()
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Specified by:
      getKind in interface RouteOrBuilder
      Returns:
      The kind.
    • getKindBytes

      public com.google.protobuf.ByteString getKindBytes()
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Specified by:
      getKindBytes in interface RouteOrBuilder
      Returns:
      The bytes for kind.
    • setKind

      public Route.Builder setKind(String value)
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Parameters:
      value - The kind to set.
      Returns:
      This builder for chaining.
    • clearKind

      public Route.Builder clearKind()
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Returns:
      This builder for chaining.
    • setKindBytes

      public Route.Builder setKindBytes(com.google.protobuf.ByteString value)
       Output only. [Output Only] Type of this resource. Always compute#routes for
       Route resources.
       
      optional string kind = 3292052;
      Parameters:
      value - The bytes for kind to set.
      Returns:
      This builder for chaining.
    • hasName

      public boolean hasName()
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Specified by:
      hasName in interface RouteOrBuilder
      Returns:
      Whether the name field is set.
    • getName

      public String getName()
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Specified by:
      getName in interface RouteOrBuilder
      Returns:
      The name.
    • getNameBytes

      public com.google.protobuf.ByteString getNameBytes()
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Specified by:
      getNameBytes in interface RouteOrBuilder
      Returns:
      The bytes for name.
    • setName

      public Route.Builder setName(String value)
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Parameters:
      value - The name to set.
      Returns:
      This builder for chaining.
    • clearName

      public Route.Builder clearName()
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Returns:
      This builder for chaining.
    • setNameBytes

      public Route.Builder setNameBytes(com.google.protobuf.ByteString value)
       Name of the resource. Provided by the client when the resource is created.
       The name must be 1-63 characters long, and comply withRFC1035.
       Specifically, the name must be 1-63 characters long and match the regular
       expression `[a-z]([-a-z0-9]*[a-z0-9])?`. The first character must be a
       lowercase letter, and all following characters (except for the last
       character) must be a dash, lowercase letter, or digit. The last character
       must be a lowercase letter or digit.
       
      optional string name = 3373707;
      Parameters:
      value - The bytes for name to set.
      Returns:
      This builder for chaining.
    • hasNetwork

      public boolean hasNetwork()
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Specified by:
      hasNetwork in interface RouteOrBuilder
      Returns:
      Whether the network field is set.
    • getNetwork

      public String getNetwork()
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Specified by:
      getNetwork in interface RouteOrBuilder
      Returns:
      The network.
    • getNetworkBytes

      public com.google.protobuf.ByteString getNetworkBytes()
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Specified by:
      getNetworkBytes in interface RouteOrBuilder
      Returns:
      The bytes for network.
    • setNetwork

      public Route.Builder setNetwork(String value)
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Parameters:
      value - The network to set.
      Returns:
      This builder for chaining.
    • clearNetwork

      public Route.Builder clearNetwork()
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Returns:
      This builder for chaining.
    • setNetworkBytes

      public Route.Builder setNetworkBytes(com.google.protobuf.ByteString value)
       Fully-qualified URL of the network that this route applies to.
       
      optional string network = 232872494;
      Parameters:
      value - The bytes for network to set.
      Returns:
      This builder for chaining.
    • hasNextHopGateway

      public boolean hasNextHopGateway()
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Specified by:
      hasNextHopGateway in interface RouteOrBuilder
      Returns:
      Whether the nextHopGateway field is set.
    • getNextHopGateway

      public String getNextHopGateway()
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Specified by:
      getNextHopGateway in interface RouteOrBuilder
      Returns:
      The nextHopGateway.
    • getNextHopGatewayBytes

      public com.google.protobuf.ByteString getNextHopGatewayBytes()
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Specified by:
      getNextHopGatewayBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopGateway.
    • setNextHopGateway

      public Route.Builder setNextHopGateway(String value)
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Parameters:
      value - The nextHopGateway to set.
      Returns:
      This builder for chaining.
    • clearNextHopGateway

      public Route.Builder clearNextHopGateway()
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Returns:
      This builder for chaining.
    • setNextHopGatewayBytes

      public Route.Builder setNextHopGatewayBytes(com.google.protobuf.ByteString value)
       The URL to a gateway that should handle matching packets.
       You can only specify the internet gateway using a full or
       partial valid URL: projects/project/global/gateways/default-internet-gateway
       
      optional string next_hop_gateway = 377175298;
      Parameters:
      value - The bytes for nextHopGateway to set.
      Returns:
      This builder for chaining.
    • hasNextHopHub

      public boolean hasNextHopHub()
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Specified by:
      hasNextHopHub in interface RouteOrBuilder
      Returns:
      Whether the nextHopHub field is set.
    • getNextHopHub

      public String getNextHopHub()
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Specified by:
      getNextHopHub in interface RouteOrBuilder
      Returns:
      The nextHopHub.
    • getNextHopHubBytes

      public com.google.protobuf.ByteString getNextHopHubBytes()
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Specified by:
      getNextHopHubBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopHub.
    • setNextHopHub

      public Route.Builder setNextHopHub(String value)
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Parameters:
      value - The nextHopHub to set.
      Returns:
      This builder for chaining.
    • clearNextHopHub

      public Route.Builder clearNextHopHub()
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Returns:
      This builder for chaining.
    • setNextHopHubBytes

      public Route.Builder setNextHopHubBytes(com.google.protobuf.ByteString value)
       Output only. [Output Only] The full resource name of the Network Connectivity Center hub
       that will handle matching packets.
       
      optional string next_hop_hub = 198679219;
      Parameters:
      value - The bytes for nextHopHub to set.
      Returns:
      This builder for chaining.
    • hasNextHopIlb

      public boolean hasNextHopIlb()
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Specified by:
      hasNextHopIlb in interface RouteOrBuilder
      Returns:
      Whether the nextHopIlb field is set.
    • getNextHopIlb

      public String getNextHopIlb()
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Specified by:
      getNextHopIlb in interface RouteOrBuilder
      Returns:
      The nextHopIlb.
    • getNextHopIlbBytes

      public com.google.protobuf.ByteString getNextHopIlbBytes()
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Specified by:
      getNextHopIlbBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopIlb.
    • setNextHopIlb

      public Route.Builder setNextHopIlb(String value)
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Parameters:
      value - The nextHopIlb to set.
      Returns:
      This builder for chaining.
    • clearNextHopIlb

      public Route.Builder clearNextHopIlb()
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Returns:
      This builder for chaining.
    • setNextHopIlbBytes

      public Route.Builder setNextHopIlbBytes(com.google.protobuf.ByteString value)
       The URL to a forwarding rule of typeloadBalancingScheme=INTERNAL that should handle matching
       packets or the IP address of the forwarding Rule.
       For example, the following are all valid URLs:
      
      
       - https://www.googleapis.com/compute/v1/projects/project/regions/region/forwardingRules/forwardingRule
       - regions/region/forwardingRules/forwardingRule
      
      
       If an IP address is provided, must specify an IPv4 address in dot-decimal
       notation or an IPv6 address in RFC 4291 format. For example, the following
       are all valid IP addresses:
      
      
       - 10.128.0.56
       - 2001:db8::2d9:51:0:0
       - 2001:db8:0:0:2d9:51:0:0
      
      
       IPv6 addresses will be displayed using RFC 5952 compressed format (e.g.
       2001:db8::2d9:51:0:0). Should never be an IPv4-mapped IPv6 address.
       
      optional string next_hop_ilb = 198679901;
      Parameters:
      value - The bytes for nextHopIlb to set.
      Returns:
      This builder for chaining.
    • hasNextHopInstance

      public boolean hasNextHopInstance()
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Specified by:
      hasNextHopInstance in interface RouteOrBuilder
      Returns:
      Whether the nextHopInstance field is set.
    • getNextHopInstance

      public String getNextHopInstance()
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Specified by:
      getNextHopInstance in interface RouteOrBuilder
      Returns:
      The nextHopInstance.
    • getNextHopInstanceBytes

      public com.google.protobuf.ByteString getNextHopInstanceBytes()
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Specified by:
      getNextHopInstanceBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopInstance.
    • setNextHopInstance

      public Route.Builder setNextHopInstance(String value)
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Parameters:
      value - The nextHopInstance to set.
      Returns:
      This builder for chaining.
    • clearNextHopInstance

      public Route.Builder clearNextHopInstance()
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Returns:
      This builder for chaining.
    • setNextHopInstanceBytes

      public Route.Builder setNextHopInstanceBytes(com.google.protobuf.ByteString value)
       The URL to an instance that should handle matching packets. You can specify
       this as a full or partial URL.
       For example:
       https://www.googleapis.com/compute/v1/projects/project/zones/zone/instances/
       
      optional string next_hop_instance = 393508247;
      Parameters:
      value - The bytes for nextHopInstance to set.
      Returns:
      This builder for chaining.
    • hasNextHopInterRegionCost

      public boolean hasNextHopInterRegionCost()
       Output only. [Output only] Internal fixed region-to-region cost that Google Cloud
       calculates based on factors such as network performance, distance, and
       available bandwidth between regions.
       
      optional uint32 next_hop_inter_region_cost = 24442003;
      Specified by:
      hasNextHopInterRegionCost in interface RouteOrBuilder
      Returns:
      Whether the nextHopInterRegionCost field is set.
    • getNextHopInterRegionCost

      public int getNextHopInterRegionCost()
       Output only. [Output only] Internal fixed region-to-region cost that Google Cloud
       calculates based on factors such as network performance, distance, and
       available bandwidth between regions.
       
      optional uint32 next_hop_inter_region_cost = 24442003;
      Specified by:
      getNextHopInterRegionCost in interface RouteOrBuilder
      Returns:
      The nextHopInterRegionCost.
    • setNextHopInterRegionCost

      public Route.Builder setNextHopInterRegionCost(int value)
       Output only. [Output only] Internal fixed region-to-region cost that Google Cloud
       calculates based on factors such as network performance, distance, and
       available bandwidth between regions.
       
      optional uint32 next_hop_inter_region_cost = 24442003;
      Parameters:
      value - The nextHopInterRegionCost to set.
      Returns:
      This builder for chaining.
    • clearNextHopInterRegionCost

      public Route.Builder clearNextHopInterRegionCost()
       Output only. [Output only] Internal fixed region-to-region cost that Google Cloud
       calculates based on factors such as network performance, distance, and
       available bandwidth between regions.
       
      optional uint32 next_hop_inter_region_cost = 24442003;
      Returns:
      This builder for chaining.
    • hasNextHopInterconnectAttachment

      public boolean hasNextHopInterconnectAttachment()
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Specified by:
      hasNextHopInterconnectAttachment in interface RouteOrBuilder
      Returns:
      Whether the nextHopInterconnectAttachment field is set.
    • getNextHopInterconnectAttachment

      public String getNextHopInterconnectAttachment()
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Specified by:
      getNextHopInterconnectAttachment in interface RouteOrBuilder
      Returns:
      The nextHopInterconnectAttachment.
    • getNextHopInterconnectAttachmentBytes

      public com.google.protobuf.ByteString getNextHopInterconnectAttachmentBytes()
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Specified by:
      getNextHopInterconnectAttachmentBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopInterconnectAttachment.
    • setNextHopInterconnectAttachment

      public Route.Builder setNextHopInterconnectAttachment(String value)
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Parameters:
      value - The nextHopInterconnectAttachment to set.
      Returns:
      This builder for chaining.
    • clearNextHopInterconnectAttachment

      public Route.Builder clearNextHopInterconnectAttachment()
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Returns:
      This builder for chaining.
    • setNextHopInterconnectAttachmentBytes

      public Route.Builder setNextHopInterconnectAttachmentBytes(com.google.protobuf.ByteString value)
       Output only. [Output Only] The URL to an InterconnectAttachment which is the next hop
       for the route.
       This field will only be populated for dynamic routes generated by
       Cloud Router with a linked interconnectAttachment or the static route
       generated by each L2 Interconnect Attachment.
       
      optional string next_hop_interconnect_attachment = 226852914;
      Parameters:
      value - The bytes for nextHopInterconnectAttachment to set.
      Returns:
      This builder for chaining.
    • hasNextHopIp

      public boolean hasNextHopIp()
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Specified by:
      hasNextHopIp in interface RouteOrBuilder
      Returns:
      Whether the nextHopIp field is set.
    • getNextHopIp

      public String getNextHopIp()
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Specified by:
      getNextHopIp in interface RouteOrBuilder
      Returns:
      The nextHopIp.
    • getNextHopIpBytes

      public com.google.protobuf.ByteString getNextHopIpBytes()
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Specified by:
      getNextHopIpBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopIp.
    • setNextHopIp

      public Route.Builder setNextHopIp(String value)
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Parameters:
      value - The nextHopIp to set.
      Returns:
      This builder for chaining.
    • clearNextHopIp

      public Route.Builder clearNextHopIp()
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Returns:
      This builder for chaining.
    • setNextHopIpBytes

      public Route.Builder setNextHopIpBytes(com.google.protobuf.ByteString value)
       The network IP address of an instance that should handle matching packets.
       Both IPv6 address and IPv4 addresses are supported.
       Must specify an IPv4 address in dot-decimal notation (e.g. 192.0.2.99) or
       an IPv6 address in RFC 4291 format (e.g. 2001:db8::2d9:51:0:0 or
       2001:db8:0:0:2d9:51:0:0). IPv6 addresses will be displayed using RFC 5952
       compressed format (e.g. 2001:db8::2d9:51:0:0). Should never be an
       IPv4-mapped IPv6 address.
       
      optional string next_hop_ip = 110319529;
      Parameters:
      value - The bytes for nextHopIp to set.
      Returns:
      This builder for chaining.
    • hasNextHopMed

      public boolean hasNextHopMed()
       Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates
       the desirability of a particular route in a network.
       
      optional uint32 next_hop_med = 198683530;
      Specified by:
      hasNextHopMed in interface RouteOrBuilder
      Returns:
      Whether the nextHopMed field is set.
    • getNextHopMed

      public int getNextHopMed()
       Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates
       the desirability of a particular route in a network.
       
      optional uint32 next_hop_med = 198683530;
      Specified by:
      getNextHopMed in interface RouteOrBuilder
      Returns:
      The nextHopMed.
    • setNextHopMed

      public Route.Builder setNextHopMed(int value)
       Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates
       the desirability of a particular route in a network.
       
      optional uint32 next_hop_med = 198683530;
      Parameters:
      value - The nextHopMed to set.
      Returns:
      This builder for chaining.
    • clearNextHopMed

      public Route.Builder clearNextHopMed()
       Output only. [Output Only] Multi-Exit Discriminator, a BGP route metric that indicates
       the desirability of a particular route in a network.
       
      optional uint32 next_hop_med = 198683530;
      Returns:
      This builder for chaining.
    • hasNextHopNetwork

      public boolean hasNextHopNetwork()
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Specified by:
      hasNextHopNetwork in interface RouteOrBuilder
      Returns:
      Whether the nextHopNetwork field is set.
    • getNextHopNetwork

      public String getNextHopNetwork()
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Specified by:
      getNextHopNetwork in interface RouteOrBuilder
      Returns:
      The nextHopNetwork.
    • getNextHopNetworkBytes

      public com.google.protobuf.ByteString getNextHopNetworkBytes()
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Specified by:
      getNextHopNetworkBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopNetwork.
    • setNextHopNetwork

      public Route.Builder setNextHopNetwork(String value)
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Parameters:
      value - The nextHopNetwork to set.
      Returns:
      This builder for chaining.
    • clearNextHopNetwork

      public Route.Builder clearNextHopNetwork()
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Returns:
      This builder for chaining.
    • setNextHopNetworkBytes

      public Route.Builder setNextHopNetworkBytes(com.google.protobuf.ByteString value)
       The URL of the local network if it should handle matching packets.
       
      optional string next_hop_network = 262295788;
      Parameters:
      value - The bytes for nextHopNetwork to set.
      Returns:
      This builder for chaining.
    • hasNextHopOrigin

      public boolean hasNextHopOrigin()
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Specified by:
      hasNextHopOrigin in interface RouteOrBuilder
      Returns:
      Whether the nextHopOrigin field is set.
    • getNextHopOrigin

      public String getNextHopOrigin()
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Specified by:
      getNextHopOrigin in interface RouteOrBuilder
      Returns:
      The nextHopOrigin.
    • getNextHopOriginBytes

      public com.google.protobuf.ByteString getNextHopOriginBytes()
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Specified by:
      getNextHopOriginBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopOrigin.
    • setNextHopOrigin

      public Route.Builder setNextHopOrigin(String value)
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Parameters:
      value - The nextHopOrigin to set.
      Returns:
      This builder for chaining.
    • clearNextHopOrigin

      public Route.Builder clearNextHopOrigin()
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Returns:
      This builder for chaining.
    • setNextHopOriginBytes

      public Route.Builder setNextHopOriginBytes(com.google.protobuf.ByteString value)
       Output only. [Output Only] Indicates the origin of the route. Can be IGP
       (Interior Gateway Protocol), EGP (Exterior Gateway Protocol),
       or INCOMPLETE.
       Check the NextHopOrigin enum for the list of possible values.
       
      optional string next_hop_origin = 48752808;
      Parameters:
      value - The bytes for nextHopOrigin to set.
      Returns:
      This builder for chaining.
    • hasNextHopPeering

      public boolean hasNextHopPeering()
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Specified by:
      hasNextHopPeering in interface RouteOrBuilder
      Returns:
      Whether the nextHopPeering field is set.
    • getNextHopPeering

      public String getNextHopPeering()
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Specified by:
      getNextHopPeering in interface RouteOrBuilder
      Returns:
      The nextHopPeering.
    • getNextHopPeeringBytes

      public com.google.protobuf.ByteString getNextHopPeeringBytes()
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Specified by:
      getNextHopPeeringBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopPeering.
    • setNextHopPeering

      public Route.Builder setNextHopPeering(String value)
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Parameters:
      value - The nextHopPeering to set.
      Returns:
      This builder for chaining.
    • clearNextHopPeering

      public Route.Builder clearNextHopPeering()
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Returns:
      This builder for chaining.
    • setNextHopPeeringBytes

      public Route.Builder setNextHopPeeringBytes(com.google.protobuf.ByteString value)
       Output only. [Output Only] The network peering name that should handle matching packets,
       which should conform to RFC1035.
       
      optional string next_hop_peering = 412682750;
      Parameters:
      value - The bytes for nextHopPeering to set.
      Returns:
      This builder for chaining.
    • hasNextHopVpnTunnel

      public boolean hasNextHopVpnTunnel()
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Specified by:
      hasNextHopVpnTunnel in interface RouteOrBuilder
      Returns:
      Whether the nextHopVpnTunnel field is set.
    • getNextHopVpnTunnel

      public String getNextHopVpnTunnel()
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Specified by:
      getNextHopVpnTunnel in interface RouteOrBuilder
      Returns:
      The nextHopVpnTunnel.
    • getNextHopVpnTunnelBytes

      public com.google.protobuf.ByteString getNextHopVpnTunnelBytes()
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Specified by:
      getNextHopVpnTunnelBytes in interface RouteOrBuilder
      Returns:
      The bytes for nextHopVpnTunnel.
    • setNextHopVpnTunnel

      public Route.Builder setNextHopVpnTunnel(String value)
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Parameters:
      value - The nextHopVpnTunnel to set.
      Returns:
      This builder for chaining.
    • clearNextHopVpnTunnel

      public Route.Builder clearNextHopVpnTunnel()
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Returns:
      This builder for chaining.
    • setNextHopVpnTunnelBytes

      public Route.Builder setNextHopVpnTunnelBytes(com.google.protobuf.ByteString value)
       The URL to a VpnTunnel that should handle matching packets.
       
      optional string next_hop_vpn_tunnel = 519844501;
      Parameters:
      value - The bytes for nextHopVpnTunnel to set.
      Returns:
      This builder for chaining.
    • hasParams

      public boolean hasParams()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
      Specified by:
      hasParams in interface RouteOrBuilder
      Returns:
      Whether the params field is set.
    • getParams

      public RouteParams getParams()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
      Specified by:
      getParams in interface RouteOrBuilder
      Returns:
      The params.
    • setParams

      public Route.Builder setParams(RouteParams value)
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
    • setParams

      public Route.Builder setParams(RouteParams.Builder builderForValue)
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
    • mergeParams

      public Route.Builder mergeParams(RouteParams value)
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
    • clearParams

      public Route.Builder clearParams()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
    • getParamsBuilder

      public RouteParams.Builder getParamsBuilder()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
    • getParamsOrBuilder

      public RouteParamsOrBuilder getParamsOrBuilder()
       Input only. [Input Only] Additional params passed with the request, but not persisted
       as part of resource payload.
       
      optional .google.cloud.compute.v1.RouteParams params = 78313862;
      Specified by:
      getParamsOrBuilder in interface RouteOrBuilder
    • hasPriority

      public boolean hasPriority()
       The priority of this route. Priority is used to break ties in cases
       where there is more than one matching route of equal prefix length. In
       cases where multiple routes have equal prefix length, the one with the
       lowest-numbered priority value wins. The default value is `1000`. The
       priority value must be from `0` to `65535`, inclusive.
       
      optional uint32 priority = 445151652;
      Specified by:
      hasPriority in interface RouteOrBuilder
      Returns:
      Whether the priority field is set.
    • getPriority

      public int getPriority()
       The priority of this route. Priority is used to break ties in cases
       where there is more than one matching route of equal prefix length. In
       cases where multiple routes have equal prefix length, the one with the
       lowest-numbered priority value wins. The default value is `1000`. The
       priority value must be from `0` to `65535`, inclusive.
       
      optional uint32 priority = 445151652;
      Specified by:
      getPriority in interface RouteOrBuilder
      Returns:
      The priority.
    • setPriority

      public Route.Builder setPriority(int value)
       The priority of this route. Priority is used to break ties in cases
       where there is more than one matching route of equal prefix length. In
       cases where multiple routes have equal prefix length, the one with the
       lowest-numbered priority value wins. The default value is `1000`. The
       priority value must be from `0` to `65535`, inclusive.
       
      optional uint32 priority = 445151652;
      Parameters:
      value - The priority to set.
      Returns:
      This builder for chaining.
    • clearPriority

      public Route.Builder clearPriority()
       The priority of this route. Priority is used to break ties in cases
       where there is more than one matching route of equal prefix length. In
       cases where multiple routes have equal prefix length, the one with the
       lowest-numbered priority value wins. The default value is `1000`. The
       priority value must be from `0` to `65535`, inclusive.
       
      optional uint32 priority = 445151652;
      Returns:
      This builder for chaining.
    • hasRouteStatus

      public boolean hasRouteStatus()
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Specified by:
      hasRouteStatus in interface RouteOrBuilder
      Returns:
      Whether the routeStatus field is set.
    • getRouteStatus

      public String getRouteStatus()
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Specified by:
      getRouteStatus in interface RouteOrBuilder
      Returns:
      The routeStatus.
    • getRouteStatusBytes

      public com.google.protobuf.ByteString getRouteStatusBytes()
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Specified by:
      getRouteStatusBytes in interface RouteOrBuilder
      Returns:
      The bytes for routeStatus.
    • setRouteStatus

      public Route.Builder setRouteStatus(String value)
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Parameters:
      value - The routeStatus to set.
      Returns:
      This builder for chaining.
    • clearRouteStatus

      public Route.Builder clearRouteStatus()
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Returns:
      This builder for chaining.
    • setRouteStatusBytes

      public Route.Builder setRouteStatusBytes(com.google.protobuf.ByteString value)
       [Output only] The status of the route. This status applies to
       dynamic routes learned by Cloud Routers. It is also applicable to routes
       undergoing migration.
       Check the RouteStatus enum for the list of possible values.
       
      optional string route_status = 418162344;
      Parameters:
      value - The bytes for routeStatus to set.
      Returns:
      This builder for chaining.
    • hasRouteType

      public boolean hasRouteType()
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Specified by:
      hasRouteType in interface RouteOrBuilder
      Returns:
      Whether the routeType field is set.
    • getRouteType

      public String getRouteType()
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Specified by:
      getRouteType in interface RouteOrBuilder
      Returns:
      The routeType.
    • getRouteTypeBytes

      public com.google.protobuf.ByteString getRouteTypeBytes()
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Specified by:
      getRouteTypeBytes in interface RouteOrBuilder
      Returns:
      The bytes for routeType.
    • setRouteType

      public Route.Builder setRouteType(String value)
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Parameters:
      value - The routeType to set.
      Returns:
      This builder for chaining.
    • clearRouteType

      public Route.Builder clearRouteType()
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Returns:
      This builder for chaining.
    • setRouteTypeBytes

      public Route.Builder setRouteTypeBytes(com.google.protobuf.ByteString value)
       Output only. [Output Only] The type of this route, which can be one of the following
       values:
       - 'TRANSIT' for a transit route that this router learned from
       another Cloud Router and will readvertise to one of its BGP peers
       - 'SUBNET' for a route from a subnet of the VPC
       - 'BGP' for a route learned from a BGP peer of this router
       - 'STATIC' for a static route
       Check the RouteType enum for the list of possible values.
       
      optional string route_type = 375888752;
      Parameters:
      value - The bytes for routeType to set.
      Returns:
      This builder for chaining.
    • hasSelfLink

      public boolean hasSelfLink()
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Specified by:
      hasSelfLink in interface RouteOrBuilder
      Returns:
      Whether the selfLink field is set.
    • getSelfLink

      public String getSelfLink()
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Specified by:
      getSelfLink in interface RouteOrBuilder
      Returns:
      The selfLink.
    • getSelfLinkBytes

      public com.google.protobuf.ByteString getSelfLinkBytes()
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Specified by:
      getSelfLinkBytes in interface RouteOrBuilder
      Returns:
      The bytes for selfLink.
    • setSelfLink

      public Route.Builder setSelfLink(String value)
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Parameters:
      value - The selfLink to set.
      Returns:
      This builder for chaining.
    • clearSelfLink

      public Route.Builder clearSelfLink()
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Returns:
      This builder for chaining.
    • setSelfLinkBytes

      public Route.Builder setSelfLinkBytes(com.google.protobuf.ByteString value)
       [Output Only] Server-defined fully-qualified URL for this resource.
       
      optional string self_link = 456214797;
      Parameters:
      value - The bytes for selfLink to set.
      Returns:
      This builder for chaining.
    • getTagsList

      public com.google.protobuf.ProtocolStringList getTagsList()
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Specified by:
      getTagsList in interface RouteOrBuilder
      Returns:
      A list containing the tags.
    • getTagsCount

      public int getTagsCount()
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Specified by:
      getTagsCount in interface RouteOrBuilder
      Returns:
      The count of tags.
    • getTags

      public String getTags(int index)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Specified by:
      getTags in interface RouteOrBuilder
      Parameters:
      index - The index of the element to return.
      Returns:
      The tags at the given index.
    • getTagsBytes

      public com.google.protobuf.ByteString getTagsBytes(int index)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Specified by:
      getTagsBytes in interface RouteOrBuilder
      Parameters:
      index - The index of the value to return.
      Returns:
      The bytes of the tags at the given index.
    • setTags

      public Route.Builder setTags(int index, String value)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Parameters:
      index - The index to set the value at.
      value - The tags to set.
      Returns:
      This builder for chaining.
    • addTags

      public Route.Builder addTags(String value)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Parameters:
      value - The tags to add.
      Returns:
      This builder for chaining.
    • addAllTags

      public Route.Builder addAllTags(Iterable<String> values)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Parameters:
      values - The tags to add.
      Returns:
      This builder for chaining.
    • clearTags

      public Route.Builder clearTags()
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Returns:
      This builder for chaining.
    • addTagsBytes

      public Route.Builder addTagsBytes(com.google.protobuf.ByteString value)
       A list of instance tags to which this route applies.
       
      repeated string tags = 3552281;
      Parameters:
      value - The bytes of the tags to add.
      Returns:
      This builder for chaining.
    • getWarningsList

      public List<Warnings> getWarningsList()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
      Specified by:
      getWarningsList in interface RouteOrBuilder
    • getWarningsCount

      public int getWarningsCount()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
      Specified by:
      getWarningsCount in interface RouteOrBuilder
    • getWarnings

      public Warnings getWarnings(int index)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
      Specified by:
      getWarnings in interface RouteOrBuilder
    • setWarnings

      public Route.Builder setWarnings(int index, Warnings value)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • setWarnings

      public Route.Builder setWarnings(int index, Warnings.Builder builderForValue)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • addWarnings

      public Route.Builder addWarnings(Warnings value)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • addWarnings

      public Route.Builder addWarnings(int index, Warnings value)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • addWarnings

      public Route.Builder addWarnings(Warnings.Builder builderForValue)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • addWarnings

      public Route.Builder addWarnings(int index, Warnings.Builder builderForValue)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • addAllWarnings

      public Route.Builder addAllWarnings(Iterable<? extends Warnings> values)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • clearWarnings

      public Route.Builder clearWarnings()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • removeWarnings

      public Route.Builder removeWarnings(int index)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • getWarningsBuilder

      public Warnings.Builder getWarningsBuilder(int index)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • getWarningsOrBuilder

      public WarningsOrBuilder getWarningsOrBuilder(int index)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
      Specified by:
      getWarningsOrBuilder in interface RouteOrBuilder
    • getWarningsOrBuilderList

      public List<? extends WarningsOrBuilder> getWarningsOrBuilderList()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
      Specified by:
      getWarningsOrBuilderList in interface RouteOrBuilder
    • addWarningsBuilder

      public Warnings.Builder addWarningsBuilder()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • addWarningsBuilder

      public Warnings.Builder addWarningsBuilder(int index)
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;
    • getWarningsBuilderList

      public List<Warnings.Builder> getWarningsBuilderList()
       Output only. [Output Only] If potential misconfigurations are detected for this
       route, this field will be populated with warning messages.
       
      repeated .google.cloud.compute.v1.Warnings warnings = 498091095;